Opened 10 years ago

Closed 5 years ago

#524 closed defect (fixed)

GetSelectionXML causes "resource was busy" error, crashes server

Reported by: macieksk Owned by: trevorwekel
Priority: high Milestone:
Component: General Version: 2.0.0
Severity: major Keywords: getselection setselection
Cc: External ID:

Description

Hi

when i use onclick event (when user click on map ex. polygon i create pop-up window whit all information about object - i get xml whit ID of this object from GetSelectionXML)


params = new Array("xml",parent.ViewerFrame?.mapFrame.GetSelectionXML() ,"SESSION",parent.ViewerFrame?.mapFrame.GetSessionId?(),"MAPNAME",encodeURIComponent(parent.ViewerFrame?.mapFrame.GetMapName?()));

parent.ViewerFrame?.formFrame.Submit("../my_folder/onselect.php", params, "scriptFrame");


i select polygon in onselect.php file...

after 1 or 2 click mgserver is down....and i get this error


szAppName : mgserver.exe szAppVer : 2.0.0.2308 szModName : msvcr80.dll szModVer : 8.0.50727.1433 offset : 00008aa0


i use this code in version 1.1, 1.2 without any problem....

i have this problme (mgserver.exe crash ) whit 2 method

GetSelectionXML(), SetSelectionXML()

Change History (6)

comment:1 Changed 10 years ago by zspitzer

Milestone: 2.1

anything in the server error.log file?

comment:2 Changed 10 years ago by macieksk2

I am also seeing a problem with the GetSelectionXML function. After I use it

the resource remains locked and I cannot perform any further actions against until I logout and log back into the application.

I can normally select the feature and then delete or update it but since updating to mgos2 I am getting this error:

Error: Please try your operation later as the resource was busy: Library://AEMSDB/Actions/487/Data/11504.FeatureSource

StackTrace?:

d:\buildforgeprojects\mapguide_open_source_v2.0\build_23.8\mgdev\server\src\services\feature\FeatureServiceHandler?.cpp

d:\buildforgeprojects\mapguide_open_source_v2.0\build_23.8\mgdev\server\src\services\feature\OpUpdateFeatures?.cpp

d:\buildforgeprojects\mapguide_open_source_v2.0\build_23.8\mgdev\server\src\services\feature\ServerUpdateFeatures?.cpp

d:\buildforgeprojects\mapguide_open_source_v2.0\build_23.8\mgdev\server\src\common\manager\FdoConnectionManager?.cpp Please try your operation later as the resource was busy: Library://AEMSDB/Actions/487/Data/11504.FeatureSource

I thought that I may have left a feature reader open somewhere but this is definately not the case.

comment:3 Changed 9 years ago by jbirch

Summary: MG 2.0 BUG...after GetSelectionXMLGetSelectionXML causes "resource was busy" error, crashes server

comment:4 Changed 9 years ago by trevorwekel

Owner: set to trevorwekel
Status: newassigned

I will investigate this defect. It may be the same root cause as ticket 716.

comment:5 Changed 8 years ago by jbirch

Please re-test against 2.1 and let us know if this is still an issue. Will close this ticket if no response by next ticket cleanup cycle.

comment:6 Changed 5 years ago by jng

Resolution: fixed
Status: assignedclosed

No activity

Note: See TracTickets for help on using tickets.