Opened 11 years ago

Closed 10 years ago

#463 closed defect (fixed)

Fusion: Tooltips do not work for any flexible layout with any layer source

Reported by: amorsell Owned by: chrisclaydon
Priority: high Milestone:
Component: Fusion Version: 2.0.0
Severity: critical Keywords:
Cc: External ID:

Description

Tooltips do not work for any flexible layout with any layer source, including the Sheboygan samples. They work for normal layouts.

The test platform is a VMWare instance running Windows XP, using the .NET web extensions, and testing with IE and Firefox.

Change History (8)

comment:1 Changed 11 years ago by jbirch

These are working for me Andy, with a similar setup except on win2k. Can you check again with 2.0.0 final?

If they're still not working, try it with Fiddler running and see what's getting returned from the server when you hover.

comment:2 Changed 11 years ago by amorsell

Summary: Tooltips not working with Fusion, RC4

I am still seeing this problem with 2.0.0 Final. When I hover over a feature, Fiddler is showing no mapagent activity at all, telling me that the AJAX callbacks are not occurring on-mouseover. With a standard web layout, I am seeing in Fiddler the OPERATION=QUERYMAPFEATURES mapagent operation for each feature hovered over. I AM NOT seeing this problem on a Linux CentOS install so it may be specific to Windows / IIS / .NET

comment:3 Changed 11 years ago by jbirch

Summary: Fusion: Tooltips do not work for any flexible layout with any layer source

comment:4 Changed 11 years ago by tomfukushima

Hi Andy, are you using the ApplicationDefinition.xml file (i.e. the one on the file system; not the ones in the repository) for your Fusion templates? If so could you try updating to the one that is in trunk and see if this fixes your problem. If you are using Studio to create the layout, this works for us, can you create a package to reproduce the problem and attach it to this ticket? Thanks, Tom

comment:5 Changed 11 years ago by amorsell

Tom, this is happening with the Sheboygan samples and I have not tried creating any new Fusion templates. I will try with the file you mention next week when I'm back in the office where that server is.

comment:6 Changed 11 years ago by tomfukushima

Owner: set to chrisclaydon

comment:7 Changed 11 years ago by madair

may be related to http://trac.osgeo.org/fusion/ticket/64, but the error I'm seeing is only with tiled maps

Tracing the error into the source file (line 1041 of ServerRenderingService??.cpp) reveals that MGOS is making a call to map->GetViewCenter??() which seems to be failing probably because the map extents have not been set for tiled layers.

To test this theory, I did a QUERYMAPFEATURES call first (which failed as above), then I made a call to GETVISIBLEMAPEXTENTS using the web tier test page, and then re-issued the same QUERYMAPFEATURES request and it worked properly.

comment:8 Changed 10 years ago by chrisclaydon

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.