Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#409 closed defect (fixed)

Rendering: black background with FORMAT!=PNG inside ajaxmappane.templ

Reported by: ulysess Owned by: trevorwekel
Priority: medium Milestone: 2.0
Component: Rendering Service Version: 2.0.0
Severity: major Keywords: rendering, ajaxmappane, format
Cc: External ID: 1052718

Description

I'm using WindowsXP and MapguideOS 2 RC1, but the problem is the same in Beta. Not tested with 1.2.

When I change in the url the variable FORMAT={GIF | JPG | JPEG} (another different to PNG), the map show the background in black. Screenshot included.

Attachments (1)

errorMapguide2.jpg (58.1 KB) - added by ulysess 11 years ago.
rendering_problems

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by ulysess

Attachment: errorMapguide2.jpg added

rendering_problems

comment:1 Changed 11 years ago by tomfukushima

Can someone check to see if this happens in MGOS 1.2 as well? Thanks, Tom

comment:2 in reply to:  1 Changed 11 years ago by ulysess

Replying to tomfukushima:

Can someone check to see if this happens in MGOS 1.2 as well? Thanks, Tom

Tested. This doesn't happens with the MGOS 1.2.

Sometimes when I use the zoom in/out, show a black background while is loading, but finally show the map (1.2)

I use WinXP+IIS+PHP with default installation on both cases (1.2 and 2.0).

comment:3 Changed 11 years ago by ulysess

Tried with RC2. The same problems.

comment:4 Changed 11 years ago by ulysess

Tried with RC3. The same problems. I think maybe is a problem with the transparent background color.

comment:5 Changed 11 years ago by ulysess

Doesn't tested with RC4 yet, but I've tried to change in bin\serverconfig.ini the renderer from AGG to GD, and with GD everythings works fine (PNG, JPG and GIF).

So the problem is the AGG renderer.

comment:6 Changed 10 years ago by trevorwekel

External ID: 1052718
Owner: set to trevorwekel
Status: newassigned

comment:7 Changed 10 years ago by trevorwekel

Resolution: fixed
Status: assignedclosed

Fix submitted for 2.0.x stream in http://trac.osgeo.org/mapguide/changeset/3028 and for trunk in http://trac.osgeo.org/mapguide/changeset/3029

Support for GIF has been fixed and PNG8 support has been implemented. The following formats will now work in ajaxmappane.templ:

PNG:  32 bit PNG with alpha
PNG8: 8 bit indexed color PNG with transparency support
GIF: 8 bit indexed color GIF with transparency support
JPG:  24 bit JPG image with no transparency

Also added experimental PNG8 tile support for 2.0.x stream http://trac.osgeo.org/mapguide/changeset/3030 and trunk http://trac.osgeo.org/mapguide/changeset/3031

Tiled images can now be rendered and served as:

PNG:  32 bit PNG with alpha
PNG8: 8 bit indexed color PNG with transparency support
JPG:  24 bit JPG image with no transparency

comment:8 Changed 10 years ago by trevorwekel

The MapGuide Server renders all tiled images in the same format. This is controlled by the serverconfig.ini file "ImageFormat" parameter.

ImageFormat = PNG8

will cause all images to be rendered and served as PNG8.

Note: See TracTickets for help on using tickets.