Opened 12 years ago

Closed 12 years ago

#30 closed defect (fixed)

Ajax and Dwf viewers do not work under IIS+PHP configuration

Reported by: trevorwekel Owned by: trevorwekel
Priority: high Milestone: 1.2
Component: AJAX Viewer Version: 1.2.0
Severity: major Keywords:
Cc: External ID: 923603

Description

Displaying a map using the IIS+PHP configuration fails with the following error:

HTTP/1.1 503 Server too busy Server: Microsoft-IIS/5.1 Date: Tue, 03 Apr 2007 20:23:08 GMT X-Powered-By: ASP.NET Connection: close Content-Type: text/html Server Error, unable to connect to fastcgi server.

Change History (2)

comment:1 Changed 12 years ago by trevorwekel

Status: newassigned

This defect was caused by the PHP 5.2.1 upgrade. The isapi_fcgi.dll has a buffer overrun defect. PHP 5.2.1 uses a larger FastCGI buffer size which uncovers the bug. The fix is to increase the buffer size in isapi_fcgi.dll. See discussion on the PHP bug list for more information:

http://bugs.php.net/bug.php?id=37448

comment:2 Changed 12 years ago by trevorwekel

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.