Opened 4 years ago

Closed 3 years ago

#2453 closed defect (fixed)

Class API documentation not transferred to .net exceptions

Reported by: jng Owned by: jng
Priority: low Milestone:
Component: Documentation Version:
Severity: trivial Keywords:
Cc: External ID:

Description

API documentation is not being transferred to .net exception.

This is because the currently generated code looks like this:

[Serializable]

///<summary>
/// Some API documentation
///</summary>
public class MyException : MgException {

When it should be this:

///<summary>
/// Some API documentation
///</summary>
[Serializable]
public class MyException : MgException {

Attachments (1)

2453.patch (4.6 KB) - added by jng 3 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 4 years ago by jng

The issue is due to [Serializable] being injected by custom code in SWIG which conflicts with our SWIG doc injection mechanism that knows nothing about this custom code.

This custom code for generating [Serializable] and .net properties is better off being served by using the partial classes feature of C# instead of custom modifications to SWIG.

Changed 3 years ago by jng

Attachment: 2453.patch added

comment:2 Changed 3 years ago by jng

Resolution: fixed
Status: newclosed

Fixed trunk (r8375, r8376) and 2.6 (r8373, r8374)

Note: See TracTickets for help on using tickets.