Opened 11 years ago

Closed 11 years ago

#242 closed defect (fixed)

Stylizer not properly parsing the geometry

Reported by: brucedechant Owned by: brucedechant
Priority: medium Milestone: 2.0
Component: Server Version: 1.2.0
Severity: major Keywords:
Cc: External ID:

Description

The methods ParseDouble?() and ParseDoublePair?() were using an uninitialized length and had an extra space in the text for the swscanf() method they were using. This was sometimes causing the length piece to remain uninitialized when the swscanf() API was executed. This in turn would cause a bad length value to be added as a pointer offset to the underlying string being parsed. This then would cause a very long loop to be processed and a possible server operation timing out because it was taking so long.

This failure was reproducible by running the server rendering unit tests in RELEASE mode. DEBUG mode did not show this error because of the padding around objects.

Change History (2)

comment:1 Changed 11 years ago by brucedechant

Owner: set to brucedechant
Status: newassigned

comment:2 Changed 11 years ago by brucedechant

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.