Opened 11 years ago

Closed 11 years ago

#235 closed defect (worksforme)

API Exception When Reading SHP data With NULL DateTime attributes

Reported by: wct Owned by:
Priority: medium Milestone:
Component: General Version: 1.2.0
Severity: major Keywords:
Cc: External ID:

Description

Windows Server 2003 / MG 1.2.0 RC1 / DotNet? API.

I receive an exception when using the Feature Service to Select Features(FeatureService?.SelectFeatures?() ) into a feature reader when having a DateTime? Field with NULL data. This is against SHP files w/ MapGuide DotNet? API. The Stack Trace:

OSGeo.MapGuide.MgInvalidArgumentException?: Invalid argument(s):

[1] = "0"

The year is invalid because it must be between 1 and 9999.

The same data displays fine in the viewer: the query options use the featureID's passed down from the viewer via the SelectionXML so I know the featureID's are valid.

Change History (5)

comment:1 Changed 11 years ago by wct

I have a sample data set I can send (exceeds attachment size limit) as well email me or reply here to make arrangements...

comment:2 Changed 11 years ago by tomfukushima

Hi wct, Thanks for taking the time to enter this ticket. I can't reproduce this with a small SHP file that I have that has NULL datetime values. Can you attach a small ASPX script with instructions that can be used to reproduce the problem? Thanks Tom.

comment:3 Changed 11 years ago by tomfukushima

Milestone: 1.2

comment:4 Changed 11 years ago by jbirch

Priority: highmedium

Dropping priority. No feedback.

comment:5 Changed 11 years ago by jbirch

Resolution: worksforme
Status: newclosed

Closing. No additional feedback, can't duplicate.

Note: See TracTickets for help on using tickets.