Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#184 closed defect (fixed)

Non-alphanumeric characters are encoded in result of DescribeSchemaAsXml() API

Reported by: ronnielouie Owned by: ronnielouie
Priority: medium Milestone: 1.2
Component: Feature Service Version: 1.2.0
Severity: major Keywords:
Cc: External ID: 936389

Description

Using a feature source that contains non-alphanumeric characters (for example '$') in the class name or properties, perform a call to DescribeSchemaAsXml?() API. The returned result will contain an encoding of the character (for example -x24- to represent the '$' character).

Change History (4)

comment:1 Changed 11 years ago by ronnielouie

Status: newassigned

comment:2 Changed 11 years ago by ronnielouie

Resolution: fixed
Status: assignedclosed

Changed FdoXmlFlags? NameAdjust? to false so that it does not encode the non-alphanumeric characters when writing to XML.

Fixed by submission http://trac.osgeo.org/mapguide/changeset/1753 Fixed by submission http://trac.osgeo.org/mapguide/changeset/1754

comment:3 Changed 11 years ago by chrisclaydon

Rolled back by submission http://trac.osgeo.org/mapguide/changeset/1797

Rolled back by submission http://trac.osgeo.org/mapguide/changeset/1798

The problems caused by the escaping of characters that are not valid in XML element names that occurred in the schema report pages will be addressed in a different way.

comment:4 Changed 11 years ago by chrisclaydon

The following two submissions fix the schema report pages to function correctly with the character escaping re-introduced by rolling back the previous changes:

Fixed by submission http://trac.osgeo.org/mapguide/changeset/1807

Fixed by submission http://trac.osgeo.org/mapguide/changeset/1808

Note: See TracTickets for help on using tickets.