Opened 8 years ago

Closed 8 years ago

#1388 closed defect (fixed)

MgMap.Create causes crash of 64 bit Web Extensions on Windows

Reported by: trevorwekel Owned by: jng
Priority: high Milestone: 2.2
Component: Web API Version: 2.2.0
Severity: blocker Keywords: web extensions 64 bit crash
Cc: External ID:

Description

On a pre-release build of 64 bit MapGuide on Windows, maps do not display even though the mapagent and web extensions can process requests. The same issue occurs under .Net and PHP. After some debugging, it was found that MgMap?.Create causes a fatal application error. See attached test.php. The following message is generated from the script:

Hello World

Session is7fdbd3ee-82b5-11df-8000-000c2939c959_en_7F0000010AFC0AFB0AFA

SiteConnection is open Resource id ok

New Mgmap ok Problem:
The application encountered a problem and could not finish the operation you just requested properly.

Solution:
If it\'s the first time you met this problem, try again or restart the application / session; otherwise, describe the steps to reproduce this problem to the server administrator for suggestions. 

Attachments (2)

test.php (2.0 KB) - added by trevorwekel 8 years ago.
Test script showing web extensions crash
reboot.patch (1.7 KB) - added by jng 8 years ago.
Test patch for updated reboot logic

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by trevorwekel

Attachment: test.php added

Test script showing web extensions crash

comment:1 Changed 8 years ago by jng

My 2c, just to add another data point.

Clean install of Windows 7 x64

MGOS 2.2 pre-beta1 x64 installer with default configuration (Apache/PHP) and Sheboygan Dataset loaded.

No reboot after installation.

My test.php output:

Hello World 

Session is7f920618-8591-11df-8000-080027db9bc5_en_7F0000010AFC0AFB0AFA 

SiteConnection is open Resource id ok 

New Mgmap ok 

Map is created A length exception occurred. 

comment:2 Changed 8 years ago by trevorwekel

After some debugging, it was determined that IIS was not picking up the MENTOR_DICTIONARY_PATH environment variable without reboot. Since the coordinate system library was not initialized, the call to MgMap.Create would fail.

One fix is to restart IIS after the installation. Jackie also found some information on IIS environment variable overrides which may be applicable. http://www.teachout.com/Blog/tabid/165/EntryId/246/Windows-Environment-Variables-Overrides-for-IIS6.aspx

comment:3 Changed 8 years ago by jng

Owner: changed from trevorwekel to jng

Changed 8 years ago by jng

Attachment: reboot.patch added

Test patch for updated reboot logic

comment:4 Changed 8 years ago by jng

Resolution: fixed
Status: newclosed

Fixed with the reintroduction of mandatory rebooting r5033.

Users who don't want to reboot can ignore the prompt and use the IIS env var override technique described here (http://www.teachout.com/Blog/tabid/165/EntryId/246/Windows-Environment-Variables-Overrides-for-IIS6.aspx)

Note: See TracTickets for help on using tickets.