Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#137 closed defect (fixed)

MapGuide 1.2.0Beta2 WebStudio , can't login to webstudio , confirmed real issue

Reported by: anonymous Owned by: zjames
Priority: high Milestone: 1.2
Component: Web Studio Version: 1.2.0
Severity: critical Keywords:
Cc: stevedang External ID: 938890

Description

From what I've found there may be some issue with the new PHP 5.2.1 or something but webstudio doesn't work, it won't let you log in...(using the correct admin password and it does work through "mapadmin" interface....) In fact I think make install didn't even copy the "webstudio" folder to webservices/www....I copied it there myself from mapguide-1.2.0beta2/Web/src/webstudio, even tried webstudio directory from previous 1.1.0 build and both do the same thing, refuse to let you login.

Change History (8)

comment:1 in reply to:  description ; Changed 11 years ago by anonymous

Forgot to mention this is on Linux Redhat FC4.

Replying to anonymous:

From what I've found there may be some issue with the new PHP 5.2.1 or something but webstudio doesn't work, it won't let you log in...(using the correct admin password and it does work through "mapadmin" interface....) INVALID account/password error In fact I think make install didn't even copy the "webstudio" folder to webservices/www....I copied it there myself from mapguide-1.2.0beta2/Web/src/webstudio, even tried webstudio directory from previous 1.1.0 build and both do the same thing, refuses to let you login complaining of invalid password/user.

comment:2 in reply to:  1 ; Changed 11 years ago by anonymous

Well, I found at least two other people with exact same problem: http://www.nabble.com/Login-error-in-1.2.0-Beta-t3674061s16610.html Not sure if they're also on Linux or using windows version....

Replying to anonymous:

Forgot to mention this is on Linux Redhat FC4.

Replying to anonymous:

From what I've found there may be some issue with the new PHP 5.2.1 or something but webstudio doesn't work, it won't let you log in...(using the correct admin password and it does work through "mapadmin" interface....) INVALID account/password error In fact I think make install didn't even copy the "webstudio" folder to webservices/www....I copied it there myself from mapguide-1.2.0beta2/Web/src/webstudio, even tried webstudio directory from previous 1.1.0 build and both do the same thing, refuses to let you login complaining of invalid password/user.

comment:3 in reply to:  2 Changed 11 years ago by anonymous

Also, changing localhost to 127.0.0.1 as suggested in Ticket#97 did not work for me, perhaps since I'm on Linux and Ticket#97 guy is on windows. http://trac.osgeo.org/mapguide/ticket/97

Replying to anonymous:

Well, I found at least two other people with exact same problem: http://www.nabble.com/Login-error-in-1.2.0-Beta-t3674061s16610.html Not sure if they're also on Linux or using windows version....

Replying to anonymous:

Forgot to mention this is on Linux Redhat FC4.

Replying to anonymous:

From what I've found there may be some issue with the new PHP 5.2.1 or something but webstudio doesn't work, it won't let you log in...(using the correct admin password and it does work through "mapadmin" interface....) INVALID account/password error In fact I think make install didn't even copy the "webstudio" folder to webservices/www....I copied it there myself from mapguide-1.2.0beta2/Web/src/webstudio, even tried webstudio directory from previous 1.1.0 build and both do the same thing, refuses to let you login complaining of invalid password/user.

comment:4 in reply to:  2 Changed 11 years ago by anonymous

One more: http://lists.osgeo.org/pipermail/mapguide-users/2007-May/006860.html

Replying to anonymous:

Well, I found at least two other people with exact same problem: http://www.nabble.com/Login-error-in-1.2.0-Beta-t3674061s16610.html Not sure if they're also on Linux or using windows version....

Replying to anonymous:

Forgot to mention this is on Linux Redhat FC4.

Replying to anonymous:

From what I've found there may be some issue with the new PHP 5.2.1 or something but webstudio doesn't work, it won't let you log in...(using the correct admin password and it does work through "mapadmin" interface....) INVALID account/password error In fact I think make install didn't even copy the "webstudio" folder to webservices/www....I copied it there myself from mapguide-1.2.0beta2/Web/src/webstudio, even tried webstudio directory from previous 1.1.0 build and both do the same thing, refuses to let you login complaining of invalid password/user.

comment:5 Changed 11 years ago by zjames

Milestone: 1.2
Owner: set to zjames
Priority: mediumhigh
Severity: majorcritical
Status: newassigned

comment:6 Changed 11 years ago by zjames

Cc: stevedang added

Login attempts are generating an exception:


A length exception occurred.

Exception occurred in method MgUserInformation?.SetLocale? at line 180 in file c:\build_bond_area\mapguide_open_source_v1

.2\build_13.7\mgdev\common\mapguidecommon\System/UserInformation?.cpp


Which appears related to changes for ticket #107 http://trac.osgeo.org/mapguide/changeset/1654

comment:7 Changed 11 years ago by zjames

Resolution: fixed
Status: assignedclosed

Committed revision 1739. Changed default locale for broker object from 'eng' to 'en'

comment:8 Changed 11 years ago by rexszeto

External ID: 938890
Note: See TracTickets for help on using tickets.