Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1312 closed enhancement (fixed)

Support browsing data sources in ODBC editor

Reported by: jng Owned by: jng
Priority: medium Milestone: Maestro-3.0
Component: Maestro Version: 2.1.0
Severity: major Keywords: odbc browser
Cc: External ID:

Description

Browsing available DSNs in Maestro's ODBC editor currently display a not implemented message.

Implementation is actually quite simple. The FDO ODBC provider already does DSN enumeration, and this functionality is exposed through the GETCONNECTIONPROPERTYVALUES mapagent call or the MgFeatureService?.GetConnectionPropertyValues?() API. The problem is that this backend support is not exposed through the ServerConnectionI interface.

A new API needs to be added to ServerConnectionI:

string[] GetConnectionPropertyValues?(string provider, string propertyName, string partialConnString);

This will map to MgFeatureService?.GetConnectionPropertyValues?() for LocalNativeConnection? and will map to the GETCONNECTIONPROPERTYVALUES mapagent call for HttpServerConnection?

Once this is implemented, it a simple case of implementing a simple dialog that displays the values returned by this API.

Change History (2)

comment:1 Changed 9 years ago by jng

Resolution: fixed
Status: newclosed

Fixed in r4766

comment:2 Changed 8 years ago by jng

Milestone: Maestro-2.1Maestro-3.0

Milestone Maestro-2.1 deleted

Note: See TracTickets for help on using tickets.