Opened 12 years ago

Closed 11 years ago

#125 closed defect (fixed)

AJAX Viewer: Selecting result of custom search zooms to wrong location

Reported by: chrisclaydon Owned by: chrisclaydon
Priority: medium Milestone: 1.2
Component: General Version: 1.2.0
Severity: major Keywords:
Cc: External ID: 931595

Description

When the layer used for a custom search uses a different coordinate system from that used by the map, selecting a search result does not perform the necessary conversion into map coordinates, and the viewer zooms to the wrong location.

Change History (4)

comment:1 Changed 12 years ago by chrisclaydon

Resolution: fixed
Status: newclosed

comment:2 Changed 11 years ago by amorsell

Resolution: fixed
Status: closedreopened

I am still seeing this problem with 1.2.0 RC1. The layer being zoomed to is a MySQL ODBC point geometry in LL84 with the map in a state plane coordinate system. Clicking on a search result zooms to the lat lon coordinates at a scale of 1:0.001. No data is being drawn at that location since the layer is being transformed correctly.

comment:3 Changed 11 years ago by chrisclaydon

When looking for the spatial context matching the feature source, we were only looking at active contexts. We need to examine all contexts to guarantee a match. I was able to reproduce the problem described by Andy, above, and this change fixes it for me.

Fixed in 1.2.x by submission http://trac.osgeo.org/mapguide/changeset/1820

Fixed in trunk by submission http://trac.osgeo.org/mapguide/changeset/1821

comment:4 Changed 11 years ago by tomfukushima

Resolution: fixed
Status: reopenedclosed

Fixed for RC2.

Note: See TracTickets for help on using tickets.