Opened 9 years ago

Closed 9 years ago

#1044 closed enhancement (fixed)

CloseButton on the ajaxviewer taskpane

Reported by: bscott Owned by:
Priority: medium Milestone: 2.1
Component: AJAX Viewer Version: 2.0.2
Severity: minor Keywords:
Cc: External ID:

Description

Motivation: The task bar takes a lot of space thus reducing the map area. It would very usefull to have a button that close it.

I have included a very simple patch that does the job. There's an X icon that can close the taskbar. Also if a user issue a command that need to be displayed in the task bar, this one automatically reapear at the same size as defined in the weblayout.

Included is the patch plus the icon "delete.gif" taken from the mapadmin\images directory. The delete.gif need to be copied in the stdicons folder.

Bruno Scott

Attachments (7)

delete.gif (163 bytes) - added by bscott 9 years ago.
closetaskbar.2.patch (2.3 KB) - added by bscott 9 years ago.
closetaskbar.patch (2.3 KB) - added by bscott 9 years ago.
nav_band_right_arrow2.gif (913 bytes) - added by bscott 9 years ago.
nav_band_right_arrow3.gif (1007 bytes) - added by bscott 9 years ago.
closeButton.gif (913 bytes) - added by bscott 9 years ago.
closetaskbar.3.patch (4.5 KB) - added by bscott 9 years ago.

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by bscott

Attachment: delete.gif added

Changed 9 years ago by bscott

Attachment: closetaskbar.2.patch added

Changed 9 years ago by bscott

Attachment: closetaskbar.patch added

comment:1 Changed 9 years ago by bscott

Oops! Both patch are the same, i just can't delete one of them

comment:2 Changed 9 years ago by jng

I would prefer if a different icon was used instead of the delete. Preferably something like the collapse icon on the legend and property panes, but rotated 90 degrees. (like >> )

Also there should be some kind of localizable hover text for this button

Changed 9 years ago by bscott

Attachment: nav_band_right_arrow2.gif added

Changed 9 years ago by bscott

Attachment: nav_band_right_arrow3.gif added

comment:3 Changed 9 years ago by bscott

The collapsed icon for the legend and property pane are designed for white background and they are not very visible on a light gray background, i've attached 2 new icon, tell me wich one you prefer.

As for the hover text, the problem is they come from the layoutDefinition xml. the best place to put these localized text is there, but it's tough to do it this way as it require lots of modification

Change Mapguide Studio so it would include the close button in the layout Same apply for Maestro We need to find a way of modifying existing layout.

Some new string in the localized/en file is much more easier. What do you think?

Bruno

comment:4 Changed 9 years ago by jng

localized/en was what I was going to suggest :-)

I'm giving the patch a test run for aesthetics.

comment:5 Changed 9 years ago by bscott

Good, Personnaly i prefer the square one, And this button should be the first one, before the home button

Bruno

comment:6 Changed 9 years ago by jng

Yeah, the square one definitely looks better than the rounded one. I'll put this in if you can provide a localized tooltip using localized/en.

Changed 9 years ago by bscott

Attachment: closeButton.gif added

comment:7 Changed 9 years ago by bscott

There it is, Final patch file is closetaskbar.3.patch Final icon is CloseButton?.gif

I've included localization as tooltip and status bar, The close button is now the first one.

Bruno

Changed 9 years ago by bscott

Attachment: closetaskbar.3.patch added

comment:8 Changed 9 years ago by jng

Resolution: fixed
Status: newclosed

Fixed in trunk: r4116 Fixed in 2.1 branch: r4118

Note: See TracTickets for help on using tickets.