Opened 5 years ago

Closed 3 years ago

#2535 closed enhancement (duplicate)

Enhancement request - i.segment handle large images above 2 billion pixels

Reported by: dnewcomb Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: Default Version: svn-releasebranch70
Keywords: i.segment Cc:
CPU: Unspecified Platform: Linux

Description

I have a 3.6 billion pixel RGB image. i.segment currently fails with the following error message.

i.segment -d group=bsl_2012@bsl_landcover output=bsl_2012allarea_diff20_min50 threshold=.20 minsize=50 memory=15000 Loading input bands... Processing pass 1... ERROR: Invalid region id -2147480082

Looking in createsegs.c and iseg.h , it appears that the region stats are int variables, topping out at about 2 billion.

Change History (3)

comment:1 Changed 3 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:2 Changed 3 years ago by neteler

Keywords: i.segment added

Dupe of #3084 ?

comment:3 in reply to:  2 Changed 3 years ago by mlennert

Resolution: duplicate
Status: newclosed

Replying to neteler:

Dupe of #3084 ?

Yes. Sorry I didn't see this at the time.

As there have been discussions in the other ticket I'm closing this one.

Note: See TracTickets for help on using tickets.