#6309 closed defect (fixed)

garbled tiles from gdaladdo in geopackage

Reported by: tseval Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 2.0.1
Severity: normal Keywords: gdaladdo geopackage raster
Cc: dadler

Description

When generating overviews in a geopackage, you may get random bitmap data in areas of an overview tile that are not entirely covered by their child tiles. This will typically happen along the edge of the dataset.

To reproduce: Use the attached TIF image as input and convert to GeoPackage with:

 gdal_translate -of GPKG -a_srs "+proj=utm +zone=33 +datum=WGS84" 33_N5000raster_1.tif 33_n5000raster.gpkg

Then produce overviews with:

 gdaladdo -r cubic 33_n5000raster.gpkg 2 4 8 16

On my computer I always get artifacts for tile 3,0,7 (level,col,row), but I guess this may vary.

Change History (4)

comment:1 Changed 18 months ago by tseval

The source file was too big for attachment. Download from here instead:

https://data.teleplan.no:5001/fbdownload/shared-with-GDAL?k=ZHPlrPta&stdhtml=true

comment:2 Changed 17 months ago by Even Rouault

The link to the source TIF doesn't work

comment:4 Changed 17 months ago by Even Rouault

Cc: dadler added
Resolution: fixed
Status: newclosed

CC'ing David since he took inspiration from the GPKG driver for the DB2 one and may have imported those bugs as well:

trunk r33001, branches/2.0 r33002 "GPKG raster: fix various issues in update scenarios when interacting with the GDAL block cache that could result in lost/corrupted band data to be written in tiles (#6309)"

Note: See TracTickets for help on using tickets.