Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#6308 closed defect (fixed)

[2.0 regression] GTiff: implict JPEG overviews don't always work

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.0.2
Component: GDAL_Raster Version: 2.0.0
Severity: normal Keywords: gtiff jpeg
Cc:

Description

Reported as https://hub.qgis.org/issues/13536

When using a JPEG-compressed geotiff whose compressed tiles/strip are larger than 65536 bytes, getting subsampled data will generally always pick-up the first block due to a invalidation problem of the internal dataset.

This is a GDAL 2.0 problem

Change History (2)

comment:1 Changed 15 months ago by Even Rouault

Resolution: fixed
Status: newclosed

trunk r32978, branches/2.0 r32979 "GTiff: fix problem with implicit overviews of JPEG-compressed files (#6308)"

comment:2 Changed 15 months ago by Even Rouault

Summary: GTiff: implict JPEG overviews don't always work[2.0 regression] GTiff: implict JPEG overviews don't always work
Note: See TracTickets for help on using tickets.