Ticket #2382 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Fix INST_DATA setting from /usr/local/share to /usr/local/share/gdal

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone: 1.5.2
Component: ConfigBuild Version: 1.5.0
Severity: normal Keywords:
Cc:

Description

It appears that for a while (since 1.5.0?) the GDAL support data files have been getting installed in /usr/local/share instead of /usr/local/share/gdal on unix.

Change History

Changed 7 years ago by warmerdam

  • status changed from new to assigned

The problem appears to be this test. Presumably due to an upgrade to a newer version of autoconf, the datadir value changed to '${datarootdir}' so the test and fix failed.

dnl ---------------------------------------------------------------------------
dnl If datadir is set to @prefix@/share, the modify it to be 
dnl @prefix@/share/gdal.  I wish we could default this.
dnl ---------------------------------------------------------------------------
if test "$datadir" = '${prefix}/share' ; then
  datadir='${prefix}/share/gdal'
fi

Changed 7 years ago by warmerdam

  • version changed from unspecified to 1.5.0

I have confirmed the problem existed since 1.5.0, but does not appear to have afflicted 1.4.x.

Fixed in trunk (r14492) and 1.5 branch (r14493).

Changed 7 years ago by warmerdam

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.