Opened 11 years ago

Closed 11 years ago

#3 closed enhancement (duplicate)

Python GDAL can't find libproj.so

Reported by: dhelfman Owned by: aboudreault
Component: GDAL Severity: important
Keywords: Cc:

Description

Install libgdal1-1.6.0 and python-gdal, then try running the following at the python interpreter prompt:

>>> from osgeo import gdal
>>> gdal.Open( "18773_2.KAP" )

The 18773_2.KAP file is at http://torsion.org/witten/18773_2.KAP

This results in the following error message:

ERROR 6: Unable to load PROJ.4 library (libproj.so), creation of OGRCoordinateTransformation failed.

Note that if I run the following command first, then the error message does not occur:

sudo ln -s /usr/lib/libproj.so.0 /usr/lib/libproj.so

The ldd command appears to indicate that /usr/lib/libgdal1.6.0.so.1 is linked against libproj.so.0 (rather than libproj.so), so I'm not sure what's going on.

Change History (2)

comment:1 Changed 11 years ago by dhelfman

This is on a freshly installed Ubuntu Karmic virtual machine using the UbuntuGIS unstable PPA.

comment:2 Changed 11 years ago by aboudreault

Resolution: duplicate
Status: newclosed

Duplicate of #2

Note: See TracTickets for help on using tickets.