wiki:UsersWikiPostgreSQLPostGIS

Version 188 (modified by Mike Taves, 2 months ago) (diff)

rm stray '

Current best

As of 03 September 4th, 2021 these versions are latest and give you best stable feature coverage.

PostGIS Support Matrix

Versions of PostgreSQL supported by which versions of PostGIS

PostgreSQL versionPostGIS 1.3 EOLPostGIS 1.4 EOLPostGIS 1.5 EOLPostGIS 2.0 EOLPostGIS 2.1 EOL PostGIS 2.2 EOL PostGIS 2.3 EOL PostGIS 2.4PostGIS 2.5PostGIS 3.0PostGIS 3.1PostGIS 3.2
PostGIS release date 2007/08/09 2009/07/24 2010/02/04 2012/04/03 2013/08/17 2015/10/07 2016/09/26 2017/09/30 2018/09/23 2019/10/20 2020/12/18 2021/XX/XX
14NoNoNoNoNoNoNoNoNoNoYesYes
13NoNoNoNoNoNoNoNoNoYesYesYes
12NoNoNoNoNoNoNoNoYesYesYesYes
11NoNoNoNoNoNoNoYes*YesYesYesYes
10NoNoNoNoNoNoYes (not recommended)YesYesYesYesYes
9.6NoNoNoNoNoYes (not recommended)YesYesYesYesYesYes
9.5NoNoNoNoNoYesYesYesYesYesNoNo
9.4 EOLNoNoNoNoYesYesYesYesYesNoNoNo
9.3 EOLNoNoNoNoYesYesYesYesNoNoNoNo
9.2 EOLNoNoYes (not recommended)YesYesYesYesNoNoNoNoNo
9.1 EOLNoNoYesYesYesYesNoNoNoNoNoNo
9.0 EOLNoNoYesYes (not recommended)Yes (not recommended)NoNoNoNoNoNoNo
8.4 EOLYesYesYesYes (not recommended)NoNoNoNoNoNoNoNo
8.3 EOLYesYesYesNoNoNoNoNoNoNoNoNo
8.2 EOLYesYesNoNoNoNoNoNoNoNoNoNo
8.1 EOLYesNoNoNoNoNoNoNoNoNoNoNo
8.0 EOLYes (not windows)NoNoNoNoNoNoNoNoNoNoNo
7.2-7.4 EOLYes (not windows)NoNoNoNoNoNoNoNoNoNoNo

Versions of PostGIS labeled 'EOL' will no longer receive any micro updates or security patches. If you are running these you should upgrade to the latest version you can.

The not recommended note means you can compile and install with that, but you'll be missing some functionality.

* Means it currently does or doesn't but may change at release time.

If you are compiling PostGIS 2.0+ with anything less than 9.1, you will not get CREATE EXTENSION support and will also not get KNN gist distance for geometry.

As a general rule, the PostGIS Project Steering committee tries to maintain support of PostGIS for at least two versions of PostgreSQL. We most often support more than 2 PostgreSQL versions, if requirements do not necessitate bumping up requirement without too much effort. We will rarely support more than 5 PostgreSQL versions on any release.

64-bit Windows version support started in PostGIS 2.0.0 (both 9.0 and 9.1)

Versions of GEOS support for PostGIS

The below chart shows which versions of GEOS work with which versions of PostGIS. The none means that you can get that version to work without GEOS, though its not recommended since a lot of functions will not be installed.

For the not recommended, this means that while you can get PostGIS to work with those versions, you'll be missing out on some PostGIS functions.

Geos VersionPostGIS 1.3 EOLPostGIS 1.4 EOLPostGIS 1.5 EOLPostGIS 2.0 EOLPostGIS 2.1 EOLPostGIS 2.2 EOLPostGIS 2.3PostGIS 2.4PostGIS 2.5PostGIS 3.0PostGIS 3.1PostGIS 3.2
3.10NoNoNoNoNoNoNoNoNoYes*YesYes
3.9NoNoNoNoNoNoNoNoNoYesYesYes
3.8YesYesYesYesYesYesYesYesYes
3.7YesYesYesYesYesYesYesYesYes
3.6YesYesYesYesYesYesYes (recommended)Yes*Yes*
3.5YesYesYesYesYesYes (recommended)Yes*Yes*Yes*
3.4YesYesYes (preferred 3.4.2+)Yes (3.4.2+)YesYes*Yes*Yes*No
3.3 EOLYesYesYes (preferred 3.3.3+)Yes (3.3.9+)Yes (not recommended)Yes*NoNoNo
3.2 EOLYesYesYesYes (not recommended)NoNoNoNoNo
3.1 EOLYesYesYes (not recommended) (requires 3.1.1+)NoNoNoNoNoNo
3.0 EOLYesYes (not recommended)NoNoNoNoNoNoNo
2.2 EOLYes (not recommended)NoNoNoNoNoNoNoNo
NoneYes (not recommended)NoNoNoNoNoNoNoNo

Versions of GDAL support for PostGIS

PostGIS raster functionality (introduced in 2.0) depends on GDAL so to get raster functionality, you'll need to compile with GDAL support and preferably 1.9 or above. Although you can compile PostGIS 2.0 without raster support, you really should rethink that decision, especially if you are a package maintainer (you'll have a lot of pissed off users if you do :)). For PostgreSQL 9.1 extension support, compiling with raster support is ABSOLUTELY required since the postgis extension includes the raster functionality.

  • Means it currently does or doesn't but may change at release time.
GDAL VersionPre - PostGIS 2.0PostGIS 2.0PostGIS 2.1PostGIS 2.2PostGIS 2.3PostGIS 2.4
2.2N/ANoNoYesYesYes
2.1N/ANoNoYesYesYes
2.0N/ANoNoYesYesYes
1.11N/AYesYesYesYesYes
1.10N/AYesYesYesYesYes
1.9N/AYesYesYesYes
1.8N/AYes (not recommended)Yes (not recommended)Yes*Yes*
1.7N/AYes (not recommended)NoNoNo

Packaging status

See UsersWikiPackages