Opened 10 years ago

Closed 9 years ago

#987 closed defect (fixed)

Bad handling of Inf values in GEOS

Reported by: pramsey Owned by: pramsey
Priority: medium Milestone: PostGIS 1.5.4
Component: postgis Version: 1.5.X
Keywords: Cc:

Description

See http://postgis.refractions.net/pipermail/postgis-users/2011-February/028999.html

Older versions of GEOS (pre 3.3) will loop infinitely when handed some coordinates with Inf values in them. Proj4 sometimes generates those values. The solution (?) in this case is to patch PostGIS to not pass the values through to GEOS.

Attachments (3)

inf.patch (513 bytes) - added by pramsey 10 years ago.
Inf testing in the GEOS handler
inf2.patch (3.2 KB) - added by pramsey 10 years ago.
Add regression tests and isvalid shortcuts
inf3.patch (2.6 KB) - added by pramsey 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by pramsey

Attachment: inf.patch added

Inf testing in the GEOS handler

comment:1 Changed 10 years ago by strk

That check would make ST_IsValid throw an exception rather than returning false. Note that ST_IsValidReason will tell you it's due to NaN / Inf ...

Changed 10 years ago by pramsey

Attachment: inf2.patch added

Add regression tests and isvalid shortcuts

Changed 10 years ago by pramsey

Attachment: inf3.patch added

comment:2 Changed 10 years ago by pramsey

Milestone: PostGIS 1.5.3PostGIS 2.0.0

Committed to 1.5 branch at r7344, should be committed to 2.0 also.

comment:3 Changed 10 years ago by robe

Milestone: PostGIS 2.0.0PostGIS 1.5.3

comment:4 Changed 10 years ago by robe

Milestone: PostGIS 1.5.3PostGIS 1.5.4

comment:5 Changed 9 years ago by pramsey

Resolution: fixed
Status: newclosed

This seems to have been applied to trunk also. Closing out.

Note: See TracTickets for help on using tickets.