Opened 10 years ago

Closed 9 years ago

#904 closed task (fixed)

PostGIS 2.0.0 stop testing on 8.3 and make 8.4 minimum

Reported by: robe Owned by: chodgson
Priority: medium Milestone: PostGIS 2.0.0
Component: management Version: master
Keywords: hudson Cc:

Description

Chris,

No rush, but when you get the chance, can you change Hudson to stop testing trunk on 8.3. I think there might be another script that tests on 8.4. We WON'T be supporting PostgreSQL 8.3 on PostGIS 2.0.

Would also be nice if it tested with the newer GEOS 3.3, but that can wait.

Change History (8)

comment:1 Changed 10 years ago by mcayland

As far as I know, we have discussed this before but no official decision has been made with regard to PostgreSQL 8.3. If we are making this decision then we need some more concise documentation for the archives specifying exactly why it has been made in order to help developers.

comment:2 Changed 10 years ago by robe

I think we should make it as a general easy to remember rule that we will NOT support more than 3 versions of any PostgreSQL release and if it happens to work don't necessarily assume it will in the next micro release. Keep in mind for each minor version of PostGIS we support, we should expect to support it for 2 years. I don't want to support PostgreSQL 8.3 for another 2 years on 2.0.

That's the main reason I want to drop 8.3. There are enough minute details between changes in what's allowed between PostgreSQL 8.4 and 8.3 to drive me crazy that I really don't want to keep on watching my back when programming or people complain of performance issues etc.

As far as besides that reason, the main reason to drop it now is: 1) we can use variadic functions which raster folks want to use and I personally would like to use too. Though you don't think its a maintenance nightmare, I can't tell you what a great burden it has been in my mind to not have my databases cluttered with 400 duplicate or legacy functions and I'm thinking wouldn't it be wonderful if I didn't have to deal with 5 variants of all those output and raster functions. We've already dropped our count of functions down by 200 or so by chucking those legacy functions and that is despite adding in 100 or so more functions.

2) That hack you have in there for pgxs to deal with 8.3, I want that removed and we can't if we are still supporting 8.3.

comment:3 Changed 10 years ago by robe

Mark,

BTW - our PostGIS 2.0 documentation has for a while said that 8.4 is the minimum. http://www.postgis.org/documentation/manual-svn/postgis_installation.html#id2979917

I have changed the matrix to do the same: http://trac.osgeo.org/postgis/wiki/UsersWikiPostgreSQLPostGIS

(It used to have a Yes? in the 8.3 column for 2.0) and have clarified the 2 but never more than 3 rule.

Where else do you think details like this need to go?

comment:4 Changed 10 years ago by robe

Now that the PSC has voted to approve drop of 8.3, I think we can now stop the regression testing on 8.3 and build on 8.3.

Chris -- can you do that when you get the chance. PostGIS developers are whining about how Hudson is badgering them every time they commit something.

comment:5 Changed 10 years ago by robe

Owner: changed from chodson to chodgson

comment:6 Changed 10 years ago by chodgson

I think I've made this change now. Let me know if you can confirm that it's working.

comment:7 Changed 10 years ago by robe

Chris, Hard to tell since we had fixed the regress issue with a hack. However I plan to be introducing some code that is incompatible with 8.3 soon. That should sure break any 8.3 still running around.

What about the GEOS 3.3 change. Though would be nice to still keep one running on 3.2 since I don't test on 3.2, but do on 3.3.

comment:8 Changed 9 years ago by robe

Resolution: fixed
Status: newclosed

I think this is done.

Note: See TracTickets for help on using tickets.