Opened 11 years ago

Closed 10 years ago

#735 closed defect (fixed)

regress failed

Reported by: aperi2007 Owned by: pramsey
Priority: medium Milestone: PostGIS 2.0.0
Component: postgis Version: main
Keywords: Cc:

Description

Hi,

during the check phase of compile the last version of postgis trunk I see three errors: regress, lwgeom-regres and ticket.


PostgreSQL 9.0.2 on i686-pc-linux-gnu, compiled by GCC gcc (Debian 4.3.2-1.1) 4.3.2, 32-bit Postgis 2.0.0SVN - 2010-12-28 15:05:59

GEOS: 3.3.0-CAPI-1.7.0 PROJ: Rel. 4.7.1, 23 September 2009

Running tests

loader/Point.............. ok loader/PointM.............. ok loader/PointZ.............. ok loader/MultiPoint.............. ok loader/MultiPointM.............. ok loader/MultiPointZ.............. ok loader/Arc.............. ok loader/ArcM.............. ok loader/ArcZ.......... ok loader/Polygon.............. ok loader/PolygonM.............. ok loader/PolygonZ.............. ok regress. failed (diff expected obtained: /tmp/pgis_reg_31671/test_13_diff) regress_index. ok regress_index_nulls. ok lwgeom_regress. failed (diff expected obtained: /tmp/pgis_reg_31671/test_16_diff) regress_lrs. ok removepoint. ok setpoint. ok simplify. ok snaptogrid. ok affine. ok measures. ok long_xact. ok ctors. ok sql-mm-serialize. ok sql-mm-circularstring. ok sql-mm-compoundcurve. ok sql-mm-curvepoly. ok sql-mm-general. ok sql-mm-multicurve. ok sql-mm-multisurface. ok polyhedralsurface. ok out_geometry. ok out_geography. ok in_gml. ok in_kml. ok iscollection. ok regress_ogc. ok regress_ogc_cover. ok regress_ogc_prep. ok regress_bdpoly. ok regress_proj. ok dump. ok dumppoints. ok wmsservers. ok tickets. failed (diff expected obtained: /tmp/pgis_reg_31671/test_47_diff) remove_repeated_points. ok split. ok relatematch. ok regress_buffer_params. ok hausdorff. ok clean. ok sharedpaths. ok snap. ok

Run tests: 55 Failed: 3 make[1]: * [check] Error 3 make[1]: Leaving directory `/home/postgres/software/postgis/postgis-2.0.0SVN/regress' make: * [check] Error 1 postgres@deb:~/software/postgis/postgis-2.0.0SVN$


also attach the logs from tmp

Regards,

Attachments (5)

tmp_logs.zip (4.7 KB) - added by aperi2007 11 years ago.
logs of errors
pgis_reg_5480.zip (10.0 KB) - added by robe 11 years ago.
regress failures on windows mingw
pgis_reg_14145.tgz (5.9 KB) - added by strk 11 years ago.
regression failures on GNU/Linux 32bit
pgis_reg_10087.tgz (4.9 KB) - added by strk 11 years ago.
failures on GNU/Linux 64bit (r6521)
pgis_reg_31238.tgz (4.1 KB) - added by strk 11 years ago.
tickets and measures regressions on 32bit GNU/Linux r6526

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by aperi2007

Attachment: tmp_logs.zip added

logs of errors

Changed 11 years ago by robe

Attachment: pgis_reg_5480.zip added

regress failures on windows mingw

comment:1 Changed 11 years ago by robe

Actually I get a lot of errors too running 9.0.0 windows (mingw 32-bit) with gserialized on. Don't recall getting this many before (aside from the one's Paul said would fail)

 PostgreSQL 9.0.0, compiled by Visual C++ build 1500, 32-bit
 Postgis 2.0.0SVN - 2010-12-28 11:45:17
   GEOS: 3.3.0-CAPI-1.7.0
   PROJ: Rel. 4.6.1, 21 August 2008

Running tests

 loader/Point.............. ok
 loader/PointM.............. ok
 loader/PointZ.............. ok
 loader/MultiPoint.............. ok
 loader/MultiPointM.............. ok
 loader/MultiPointZ.............. ok
 loader/Arc.............. ok
 loader/ArcM.............. ok
 loader/ArcZ.......... ok
 loader/Polygon.............. ok
 loader/PolygonM.............. ok
 loader/PolygonZ.............. ok
 regress. failed (diff expected obtained: /tmp/pgis_reg_5480/test_13_diff)
 regress_index. ok
 regress_index_nulls. ok
 lwgeom_regress. failed (diff expected obtained: /tmp/pgis_reg_5480/test_16_diff)
 regress_lrs. ok
 removepoint. ok
 setpoint. ok
 simplify. ok
 snaptogrid. ok
 affine. ok
 measures. ok
 long_xact. ok
 ctors. ok
 sql-mm-serialize. ok
 sql-mm-circularstring. failed (diff expected obtained: /tmp/pgis_reg_5480/test_27_diff)
 sql-mm-compoundcurve. ok
 sql-mm-curvepoly. ok
 sql-mm-general. ok
 sql-mm-multicurve. ok
 sql-mm-multisurface. ok
 polyhedralsurface. ok
 out_geometry. ok
 out_geography. ok
 in_gml. ok
 in_kml. ok
 iscollection. ok
 regress_ogc. ok
 regress_ogc_cover. ok
 regress_ogc_prep. ok
 regress_bdpoly. ok
 regress_proj. ok
 dump. failed (diff expected obtained: /tmp/pgis_reg_5480/test_44_diff)
 dumppoints. ok
 wmsservers. ok
 tickets. failed (diff expected obtained: /tmp/pgis_reg_5480/test_47_diff)
 remove_repeated_points. ok
 split. ok
 relatematch. ok
 regress_buffer_params. ok
 hausdorff. ok
 clean. ok
 sharedpaths. ok
 snap. ok

Run tests: 55
Failed: 5

Changed 11 years ago by strk

Attachment: pgis_reg_14145.tgz added

regression failures on GNU/Linux 32bit

Changed 11 years ago by strk

Attachment: pgis_reg_10087.tgz added

failures on GNU/Linux 64bit (r6521)

comment:2 Changed 11 years ago by pramsey

Resolution: fixed
Status: newclosed

Fixed at r6523

comment:3 Changed 11 years ago by strk

Resolution: fixed
Status: closedreopened

Fixed on the 64bit, still 2 failing on the 32bit (measures and tickets) Both tested as of r6526

Changed 11 years ago by strk

Attachment: pgis_reg_31238.tgz added

tickets and measures regressions on 32bit GNU/Linux r6526

comment:4 Changed 11 years ago by nicklas

Yes, strk, I did get stuck with the measures failure we discussed in #703 with 80 bit vs 64 bit, inside calculations vs variables.

I cannot understand why it doesn't get truncated to 64bit when I store it in a variable and then uses it from there.

And why can 64 bit Linux and windows handle this but not 32 bit Linux?

Before we just camouflage this behind some rounding I would like to ask: Is there anything special about this precision error. Isn't it likely that we have this issue in many places? Should I dig deeper in this to solve it, or is it just another precision problem.

/Nicklas

comment:5 in reply to:  4 Changed 11 years ago by aperi2007

And why can 64 bit Linux and windows handle this but not 32 bit Linux?

I don't know the code, but perhaps could be a variable not empty before ?

I know some difference there is between windows and unix. many compilers don't empty variable on their definition.

comment:6 Changed 11 years ago by nicklas

measures should be fixed in r6543

aperi2007, I don't think that is the problem because I initialised a variable only to do that single thing (no reuse of the variable) and it gives the tiny error about 1e-15 at first run.

/Nicklas

comment:7 Changed 10 years ago by robe

Andrea,

Are you still experiencing regression failure issues? I think everyone else is set.

comment:8 Changed 10 years ago by aperi2007

Hi robe.

The failure is fixed .

Close you this ticket ?

comment:9 Changed 10 years ago by robe

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.