Opened 11 years ago

Closed 11 years ago

#625 closed defect (fixed)

make clean does not clean raster

Reported by: robe Owned by: jorgearevalo
Priority: medium Milestone: PostGIS 2.0.0
Component: postgis Version: master
Keywords: Cc: jorge.arevalo@…

Description

We have a script that builds for 9.0, 9.1, 8.4 and noticed our dlls for rtpostgis.dll are all pointing at 9.1.

We traced it to the fact that make clean is not cleaning out raster. There also doesn't seem to be a way to do it with any of the

make rt-..

commands.

Change History (3)

comment:1 Changed 11 years ago by jorgearevalo

Cc: jorge.arevalo@… added
Owner: changed from pramsey to jorgearevalo
Status: newassigned

Hi Paul,

With the last commit (r6095), you should be able to clean raster by make clean. Specifically, make clean should:

  • Delete core objects (raster/rt_core/rt_api.o and raster/rt_core/librtcore.a)
  • Delete SQL objects (raster/rt_pg/rtpostgis.sql.in, raster/rt_pg/rtpostgis.sql, raster/rt_pg/rt_pg.o)
  • Delete test binaries (raster/test/core/testapi, raster/test/core/testwkb)
  • Delete regression test generated script(raster/test/regress/run_test)

comment:2 Changed 11 years ago by strk

Doesn't seem to be an issue anymore. Can you confirm Robe ?

comment:3 Changed 11 years ago by robe

Resolution: fixed
Status: assignedclosed

I don't recall it to be an issue, so will close this out, but unfortunately our development environment is a bit in shambles at the moment since we are in the middle of switching to use mingw-64 build environment.

We'll bug you later strk -- having issues with compiling GEOS under mingw-64, but will battle it a bit more before we bug you.

Note: See TracTickets for help on using tickets.