Opened 14 years ago

Closed 14 years ago

#601 closed defect (fixed)

shp2pgsql: *** glibc detected *** corrupted double-linked list

Reported by: kneufeld Owned by: pramsey
Priority: medium Milestone: PostGIS 1.5.2
Component: postgis Version: 1.5.X
Keywords: Cc:


When trying to load a free Waterbody.shp dataset from the City of Kamloops ( I get this error:

shp2pgsql -s 26910 -D WaterBody.shp waterbodies | psql postgis
Shapefile type: Polygon
Postgis type: MULTIPOLYGON[2]
*** glibc detected *** corrupted double-linked list: 0x09ae5220 ***
select postgis_full_version();
 POSTGIS="1.5.1" GEOS="3.2.2-CAPI-1.6.2" PROJ="Rel. 4.7.1, 23 September 2009" LIBXML="2.6.16" USE_STATS
(1 row)

Interestingly, Quantum's "Spit" loader worked just fine.

Change History (3)

comment:1 by Mike Taves, 14 years ago

Works fine with version 1.3.6, but error is reproducible with 1.5.1.

The crash happens on FID 196:

$ ogrinfo WaterBody.shp WaterBody

  FACILITYID (String) = (null)
  NAME (String) = (null)
  POLYGON ((706728.37352437433 5610997.3840159886,...

  FACILITYID (String) = (null)
  NAME (String) = (null)

  FACILITYID (String) = (null)
  NAME (String) = (null)
  POLYGON ((682101.90999524202 5614640.7300350443,...


I've confirmed with ArcGIS that FID=196 does not have any geometry.

comment:2 by mcayland, 14 years ago

I've just tried this using latest 1.5 branch SVN and it works fine for me. Can you re-test with 1.5 SVN and report back?

If it still fails, can you give us more information about your platform, etc.

comment:3 by pramsey, 14 years ago

Resolution: fixed
Status: newclosed

Confirm a crash at 1.5.1 and success at 1.5-svn, so I'm closing this out, it'll be fixed at next patch release.

Note: See TracTickets for help on using tickets.