Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#5480 closed defect (wontfix)

Old geos on docker latest image 3.4

Reported by: latot Owned by: strk
Priority: medium Milestone: PostGIS 3.4.1
Component: build Version: 3.4.x
Keywords: Cc:

Description

Hi!, I was testing the new release of 3.4 on docker, using the postgis/postgis:latest (I already pulled the new image).

And then I found this:

`

ST_LineMerge(

ST_Collect(

vpv.half2, next_geom.half1

), true

) geom ERROR: Directed line merging requires a build against GEOS-3.11 or higher, this version of PostGIS was built against version 3.9.0

`

Now idea why, the latest image is compiled with a old version of geos.

Change History (2)

comment:1 by robe, 8 months ago

Resolution: wontfix
Status: newclosed

Wrong tracker — you want to post to https://github.com/postgis/docker-postgis

comment:2 by robe, 8 months ago

related note here - https://github.com/postgis/docker-postgis/issues/351

I think the issue is they build using the GEOS shipped with the OS.

Note: See TracTickets for help on using tickets.