Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#5477 closed defect (fixed)

distclean target fails (No rule to make target 'local-clean'.)

Reported by: Bas Couwenberg Owned by: strk
Priority: medium Milestone: PostGIS 3.4.0
Component: build Version: master
Keywords: Cc: Bas Couwenberg

Description

make distclean fails:

rule=distclean; \
for lang in it_IT pt_BR fr es pl ko_KR de ja ru; do \
    echo "Making $rule for language $lang..."; \
    /usr/bin/make -C po/$lang local-$rule || exit 1; \
  done
Making distclean for language it_IT...
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/it_IT'
rm -f Makefile
rm -rf /build/postgis-3.4.0~rc3+dfsg/doc/html/postgis-web-mobile-en/
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/it_IT'
Making distclean for language pt_BR...
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/pt_BR'
rm -f Makefile
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/pt_BR'
Making distclean for language fr...
rm -f images # work around https://trac.osgeo.org/postgis/ticket/5422
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/fr'
rm -f Makefile
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/fr'
Making distclean for language es...
rm -f list_3d_functions.xsl.xml list_aggregates.xsl.xml list_box_functions.xsl.xml list_curved_geometry_functions.xsl.xml list_dump_functions.xsl.xml list_geography_functions.xsl.xml list_new_functions.xsl.xml list_raster_functions.xsl.
xml list_sqlmm_functions.xsl.xml list_window_functions.xsl.xml table_body_function_support_matrix.xsl.xml postgis-out.xml 
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/es'
rm -f Makefile
rm -f postgis-nospecial.xml
rm -f address_standardizer_required.tag curve_support.tag geography_transform.tag index_aware.tag M_support.tag P_support.tag sfcgal_enhanced.tag sfcgal_required.tag sfs_compliant.tag sqlmm_compliant.tag T_support.tag Z_support.tag
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/es'
Making distclean for language pl...
/usr/bin/make -C /build/postgis-3.4.0~rc3+dfsg/doc/html/images clean
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/pl'
rm -f Makefile
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/pl'
Making distclean for language ko_KR...
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/html/images'
rm -f styles.o generator.o
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/ko_KR'
rm -f Makefile
rm -f generator
rm -rf generator-temp-*
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/ko_KR'
Making distclean for language de...
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/html/images'
rm -f postgis_gardentest_34.sql
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/de'
rm -f Makefile
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/de'
rm -f raster_gardentest_34.sql
Making distclean for language ja...
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/ja'
rm -f Makefile
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/ja'
Making distclean for language ru...
rm -f *.tmp
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/ru'
rm -f Makefile
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/ru'
/usr/bin/make clean-localized
make[4]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc'
rule=clean; \
for lang in it_IT pt_BR fr es pl ko_KR de ja ru; do \
    echo "Making $rule for language $lang..."; \
    /usr/bin/make -C po/$lang local-$rule || exit 1; \
  done
Making clean for language it_IT...
make[5]: Entering directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/it_IT'
make[5]: *** No rule to make target 'local-clean'.  Stop.
make[5]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc/po/it_IT'
make[4]: *** [Makefile:355: clean-localized] Error 1
make[4]: Leaving directory '/build/postgis-3.4.0~rc3+dfsg/doc'

I think the problem is that distclean has removed the Makefile which provides the local-clean target.

The order should be the other way around, first clean then distclean.

Attachments (1)

distclean.patch (794 bytes ) - added by Bas Couwenberg 9 months ago.
Patch to fix distclean target, execute clean target first.

Download all attachments as: .zip

Change History (8)

by Bas Couwenberg, 9 months ago

Attachment: distclean.patch added

Patch to fix distclean target, execute clean target first.

comment:1 by Bas Couwenberg, 9 months ago

The attached patch resolves the issue, it also removes an additional generated file that wasn't removed by the html-clean target.

comment:2 by Bas Couwenberg, 9 months ago

Milestone: PostGIS 3.4.0PostGIS 3.4.1

comment:3 by robe, 9 months ago

@Bas,

Do you think this is okay to wait for 3.4.1 or would it be better if we had another rc?

comment:4 by Regina Obe <lr@…>, 9 months ago

In 704301c/git:

distclean localize patch from Bas Couwenberg
References #5477 for PostGIS 3.5.0

comment:5 by robe, 9 months ago

strk feels we should have another rc, so I'll add this to 3.4.0 and push out an rc4

comment:6 by Regina Obe <lr@…>, 9 months ago

Resolution: fixed
Status: newclosed

In 223a7f41/git:

distclean localize patch from Bas Couwenberg
Closes #5477 for PostGIS 3.4.0rc4

comment:7 by robe, 9 months ago

Milestone: PostGIS 3.4.1PostGIS 3.4.0
Note: See TracTickets for help on using tickets.