Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#5379 closed defect (fixed)

ST_Buffer is slow at being interrupted

Reported by: strk Owned by: pramsey
Priority: medium Milestone: PostGIS GEOS
Component: postgis Version: master
Keywords: Cc:

Description

As shown by running:

regress/run_test.pl -v regress/core/interrupt_buffer

The buffer code (at least as of GEOS 3.12.0dev-CAPI-1.18.0) is slow at being interrupted:

-buffer interrupted on time
+buffer interrupted late: 00:00:13.774277

The statement_timeout in the test is 100ms, the operation interrupts after more than 13 seconds. This is likely to be caused by GEOS itself

Change History (3)

comment:2 by strk, 15 months ago

Resolution: fixed
Status: newclosed

Fixed upstream, the problem was ONLY in the still unreleased GEOS-3.12.0dev, closing

comment:3 by strk, 15 months ago

github-action bot is still too slow at interrupting ST_Buffer: https://github.com/postgis/postgis/actions/runs/4893859897/jobs/8737313192

Note: See TracTickets for help on using tickets.