Opened 2 years ago

Closed 17 months ago

#5142 closed defect (fixed)

still failures on marc21 on my local system

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 3.3.3
Component: postgis Version: master
Keywords: Cc:

Description

The marc21 tests are still failing on my system and only test failing. It works fine on winnie and all other ci bots. Winnie in theory has the same setup as me, so must be something dangling on my computer somewhere. I think I get same issue against pg14 so running pg15 is not the issue.

I get this regression:

PostgreSQL 15devel on x86_64-w64-mingw32, compiled by gcc.exe (x86_64-posix-seh-rev0, Built by MinGW-W64 project) 8.1.0, 64-bit
  Postgis 3.3.0dev - (3.2.0-782-g89019fa9d) - 2022-04-30 19:54:59
  scripts 3.3.0dev 3.2.0-782-g89019fa9d
  raster scripts 3.3.0dev 3.2.0-782-g89019fa9d
  GEOS: 3.11.0dev-CAPI-1.16.0
  PROJ: 7.2.1
  SFCGAL: 1.4.1
  GDAL: GDAL 3.4.2, released 2022/03/08


 ./regress/core/out_marc21 .. failed (diff expected obtained: /projects/postgis/tmp/3.3.0dev_pg15_geos3.11_gdal3.4.2w64/test_27_diff)
-----------------------------------------------------------------------------
--- ./regress/core/out_marc21_expected  2022-04-30 15:51:40.436946700 -0400
+++ /projects/postgis/tmp/3.3.0dev_pg15_geos3.11_gdal3.4.2w64/test_27_out      2022-04-30 16:01:39.434977000 -0400
@@ -769,9 +769,9 @@
 polygon_03|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W058.795833</subfield><subfield code="e">W058.414167</subfield><subfield code="f">S051.571111</subfield><subfield code="g">S051.747222</subfield></datafield></record>
 polygon_04|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W05847.750000</subfield><subfield code="e">W05824.850000</subfield><subfield code="f">S05134.266667</subfield><subfield code="g">S05144.833333</subfield></datafield></record>
 polygon_05|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W0584745.000000</subfield><subfield code="e">W0582451.000000</subfield><subfield code="f">S0513416.000000</subfield><subfield code="g">S0514450.000000</subfield></datafield></record>
-polygon_06|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W058.795833333333334280723647680133581161499023</subfield><subfield code="e">W058.414166666666666571927635231986641883850098</subfield><subfield code="f">S051.571111111111115121730108512565493583679199</subfield><subfield code="g">S051.747222222222220011644822079688310623168945</subfield></datafield></record>
-polygon_07|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W05847.750000000000056843418860808014869689941406250</subfield><subfield code="e">W05824.849999999999994315658113919198513031005859375</subfield><subfield code="f">S05134.266666666666907303806510753929615020751953125</subfield><subfield code="g">S05144.833333333333200698689324781298637390136718750</subfield></datafield></record>
-polygon_08|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W0584745.0000000000034106051316484808921813964843750</subfield><subfield code="e">W0582450.9999999999996589394868351519107818603515625</subfield><subfield code="f">S0513416.0000000000144382283906452357769012451171875</subfield><subfield code="g">S0514449.9999999999920419213594868779182434082031250</subfield></datafield></record>
+polygon_06|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W058.795833333333334000000000000000000000000000</subfield><subfield code="e">W058.414166666666667000000000000000000000000000</subfield><subfield code="f">S051.571111111111115000000000000000000000000000</subfield><subfield code="g">S051.747222222222220000000000000000000000000000</subfield></datafield></record>
+polygon_07|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W05847.750000000000057000000000000000000000000000000</subfield><subfield code="e">W05824.849999999999994000000000000000000000000000000</subfield><subfield code="f">S05134.266666666666907000000000000000000000000000000</subfield><subfield code="g">S05144.833333333333201000000000000000000000000000000</subfield></datafield></record>
+polygon_08|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">W0584745.0000000000034110000000000000000000000000000</subfield><subfield code="e">W0582450.9999999999996590000000000000000000000000000</subfield><subfield code="f">S0513416.0000000000144380000000000000000000000000000</subfield><subfield code="g">S0514449.9999999999920420000000000000000000000000000</subfield></datafield></record>
 polygon_09|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">-0584745</subfield><subfield code="e">-0582451</subfield><subfield code="f">-0513416</subfield><subfield code="g">-0514450</subfield></datafield></record>
 polygon_10|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">-058.79583</subfield><subfield code="e">-058.41417</subfield><subfield code="f">-051.57111</subfield><subfield code="g">-051.74722</subfield></datafield></record>
 polygon_11|<record xmlns="http://www.loc.gov/MARC21/slim"><datafield tag="034" ind1="1" ind2=" "><subfield code="a">a</subfield><subfield code="d">-05847.7500</subfield><subfield code="e">-05824.8500</subfield><subfield code="f">-05134.2667</subfield><subfield code="g">-05144.8333</subfield></datafield></record>
-----------------------------------------------------------------------------

Change History (9)

comment:1 by robe, 2 years ago

Owner: changed from pramsey to robe

comment:2 by robe, 23 months ago

still haven't figured this one out. I thought it was actually passing sometimes. On winnie who should be configured like my setup, hers is fine.

comment:3 by robe, 23 months ago

Okay just figured out the difference. Winnie always tests against VC++ built PostgreSQL. In my case, I flip flop between the two. Often testing against my mingw64 built PostgreSQL.

It seems when I tests against my EDB VC++ built PostgreSQL the tests pass. When tested against mingw64 built PostgreSQL the tests fail. Looks like the last set of digits are 0'd out when testing against my mingw64 built PostgreSQL.

comment:4 by robe, 22 months ago

Milestone: PostGIS 3.3.0PostGIS 3.4.0

comment:5 by pramsey, 17 months ago

That output has a ridiculous amount of precision. Where's the dude who built it in the first place? I think you're better off dropping all the tests and we just let this functionality rot quietly.

comment:6 by robe, 17 months ago

@pramsey you are so negative. It's only failing on windows testing against mingw64 (my gcc 8.1, migth not be be failing on my gcc 12.2 (which I haven't turned on yet, since I'm struggling building proj on it). Are you getting failures too? I'll take out the 3 tests that are failing for me, they are set as separate tests anyway (polygon_06, polygon_07, polygon_08)

comment:7 by Regina Obe <lr@…>, 17 months ago

In 7248e8e/git:

Take out marc21_out tests that fail under mingw64. References #5142 for PostGIS 3.4

comment:8 by Regina Obe <lr@…>, 17 months ago

In 032d737/git:

Take out marc21_out tests that fail under mingw64. References #5142 for PostGIS 3.3.3

comment:9 by robe, 17 months ago

Milestone: PostGIS 3.4.0PostGIS 3.3.3
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.