#4968 closed defect (fixed)

Upgrade autogen.sh on PostGIS 2.4, 2.5, 3.0

Reported by: robe Owned by: robe
Priority: blocker Milestone: PostGIS 2.4.10
Component: postgis Version: 2.4.x
Keywords: Cc:

Description

It seems many with autoconf > 2.69 are struggling to compile PostGIS 2.4 and 2.5 and possibly 3.0 chains.

So I think we should backport some of the changes we made in 3.1 to those.

We can mark as a breaking change if needed. My desktop autoconf running 2.69 works fine with 3.1 and 3.2 and that has been out for a while.

Change History (4)

comment:1 by robe, 11 months ago

Summary: Upgrade configure.ac on PostGIS 2.4, 2.5, 3.0Upgrade autogen.sh on PostGIS 2.4, 2.5, 3.0

Okay looks like the reason 3.1 and 3.2 work is because of Raul's patches to autogen.sh.

I'm going to test that out and backport.

Most of his changes were to change exit to exit 1 and touch build-aux/config.rpath which is actually where winnie is complaining.

comment:2 by Regina Obe <lr@…>, 11 months ago

In 1814f8a2/git:

Backport autogen.sh changes from 3.1 to address autoconf 2.71, references #4968 for PostGIS 2.5.6

comment:3 by Regina Obe <lr@…>, 11 months ago

In f6e37c3/git:

Backport autogen.sh changes from 3.1 to address autoconf 2.71, references #4968 for PostGIS 3.0.4

comment:4 by Regina Obe <lr@…>, 11 months ago

Resolution: fixed
Status: assignedclosed

In 4f4b2005/git:

Backport autogen.sh changes from 3.1 to address autoconf 2.71, closes #4968 for PostGIS 2.4.10. Fix cu_measures test Closes #4963 Closes 4326 for PostGIS 2.4.10

Note: See TracTickets for help on using tickets.