Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#4757 closed defect (fixed)

ERROR: Invalid edge (no two distinct vertices exist)

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 2.4.10
Component: topology Version: 2.4.x
Keywords: Cc:

Description

The following snippet results in an exception:

select createtopology ('tt', 0);
select topogeo_addpoint('tt', 'POINT(0 0)');
select topogeo_addlinestring('tt', 'LINESTRING(0 -0.1,1 0,1 1,0 1,0 -0.1)'::geometry, 1);

Exception is: ERROR: Invalid edge (no two distinct vertices exist)

This probably happens also in PostGIS-2.4

Change History (5)

comment:1 by Sandro Santilli <strk@…>, 2 years ago

In 1e8036c2/git:

Handle line collapse due to snap-to-existing node

References #4757 in master branch (3.1.0dev)
Includes regression test

comment:2 by Sandro Santilli <strk@…>, 2 years ago

In 7c4106c/git:

Handle line collapse due to snap-to-existing node

References #4757 in 3.0 branch (3.0.3dev)
Includes regression test

comment:3 by Sandro Santilli <strk@…>, 2 years ago

In 4c8a707/git:

Handle line collapse due to snap-to-existing node

References #4757 in 2.5 branch (2.5.6dev)
Includes regression test

comment:4 by Sandro Santilli <strk@…>, 2 years ago

Resolution: fixed
Status: newclosed

In 79ea7bb/git:

Handle line collapse due to snap-to-existing node

Closes #4757 in 2.4 branch (2.4.10dev)
Includes regression test

comment:5 by strk, 2 years ago

Milestone: PostGIS 3.1.0PostGIS 2.4.10
Version: master2.4.x
Note: See TracTickets for help on using tickets.