Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#4734 closed defect (fixed)

regress raster on gdal_polygonize and raster_surface on GDAL 3.2 (GDAL Master)

Reported by: robe Owned by: robe
Priority: blocker Milestone: PostGIS 2.5.5
Component: raster Version: master
Keywords: Cc:

Description (last modified by robe)

I had switched debbie to testing with GDAL 2.4 on PostGIS Master because GDAL 3.2 was failing. Just retested with GDAL 3.2 (master) and still failing. Can't find the original ticket I put in.

I'm not sure if it's proj or what.

20:24:34  -------------- Dependencies -------------- 
20:24:34   GEOS config:          /var/lib/jenkins/workspace/geos/rel-3.9w64/bin/geos-config
20:24:34   GEOS version:         3.9.0dev
20:24:34   GDAL config:          /var/lib/jenkins/workspace/gdal/rel-3.2w64/bin/gdal-config
20:24:34   GDAL version:         3.2.0
20:24:34   SFCGAL config:        /usr/bin/sfcgal-config
20:24:34   SFCGAL version:       1.3.7
20:24:34   PostgreSQL config:    /var/lib/jenkins/workspace/pg/rel/pg12w64/bin/pg_config
20:24:34   PostgreSQL version:   PostgreSQL 12.3
20:24:34   PROJ4 version:        71
20:24:34   Libxml2 config:       /usr/bin/xml2-config
20:24:34   Libxml2 version:      2.9.10
20:24:34   JSON-C support:       yes
20:24:34   protobuf support:     yes
20:24:34   protobuf-c version:   1003003
20:24:34   PCRE support:         no
20:24:34   Perl:                 /usr/bin/perl
20:24:34   Wagyu:                yes
20:24:34 
20:24:34  --------------- Extensions --------------- 
20:28:35 Suite: gdal
20:28:35   Test: test_gdal_configured ...passed
20:28:35   Test: test_gdal_drivers ...passed
20:28:35   Test: test_gdal_rasterize ...passed
20:28:35   Test: test_gdal_polygonize ...FAILED
20:28:35     1. cu_gdal.c:180  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((3 1,3 2,2 2,2 3,1 3,1 6,2 6,2 7,3 7,3 8,5 8,5 6,3 6,3 3,4 3,5 3,5 1,3 1))")
20:28:35     2. cu_gdal.c:196  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((0 0,0 9,9 9,9 0,0 0),(6 7,6 8,3 8,3 7,2 7,2 6,1 6,1 3,2 3,2 2,3 2,3 1,6 1,6 2,7 2,7 3,8 3,8 6,7 6,7 7,6 7))")
20:28:35     3. cu_gdal.c:232  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((0 0,0 9,9 9,9 0,0 0),(6 7,6 8,3 8,3 7,2 7,2 6,1 6,1 3,2 3,2 2,3 2,3 1,6 1,6 2,7 2,7 3,8 3,8 6,7 6,7 7,6 7))")
20:28:35     4. cu_gdal.c:260  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((0 0,0 9,9 9,9 0,0 0),(6 7,6 8,3 8,3 7,2 7,2 6,1 6,1 3,2 3,2 2,3 2,3 1,6 1,6 2,7 2,7 3,8 3,8 6,7 6,7 7,6 7))")
20:28:35     5. cu_gdal.c:264  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((3 1,3 2,2 2,2 3,1 3,1 6,2 6,2 7,3 7,3 8,5 8,5 6,3 6,3 3,4 3,5 3,5 1,3 1))")
20:28:35     6. cu_gdal.c:295  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((3 1,3 2,2 2,2 3,1 3,1 6,2 6,2 7,3 7,3 8,5 8,5 6,3 6,3 3,4 3,5 3,5 1,3 1))")
20:28:35     7. cu_gdal.c:327  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((3 1,3 2,2 2,2 3,1 3,1 6,2 6,2 7,3 7,3 8,5 8,5 6,3 6,3 3,4 3,5 3,5 1,3 1))")
20:28:35     8. cu_gdal.c:343  - CU_ASSERT_STRING_EQUAL(wkt,"POLYGON((0 0,0 9,9 9,9 0,0 0),(6 7,6 8,3 8,3 7,2 7,2 6,1 6,1 3,2 3,2 2,3 2,3 1,6 1,6 2,7 2,7 3,8 3,8 6,7 6,7 7,6 7))")
20:28:35   Test: test_raster_to_gdal ...Warning 6: PNG driver doesn't support data type Float64. Only eight bit (Byte) and sixteen bit (UInt16) bands supported. Defaulting to Byte
20:28:35   Test: test_raster_surface ...INFO: Self-intersection at or near point 2 -2
20:28:35 INFO: Self-intersection at or near point 2 -2
20:28:35 FAILED
20:28:35     1. cu_raster_geometry.c:296  - CU_ASSERT_STRING_EQUAL(wkt,"MULTIPOLYGON(((1 0,1 -1,0 -1,0 -5,4 -5,5 -5,5 0,1 0)))")
20:28:35     2. cu_raster_geometry.c:308  - CU_ASSERT_STRING_EQUAL(wkt,"MULTIPOLYGON(((1 0,1 -1,0 -1,0 -5,4 -5,5 -5,5 0,1 0),(1 -1,1 -2,2 -2,2 -1,1 -1)))")
20:28:35     3. cu_raster_geometry.c:321  - CU_ASSERT_STRING_EQUAL(wkt,"MULTIPOLYGON(((1 -1,1 0,5 0,5 -5,4 -5,0 -5,0 -1,1 -1),(1 -1,1 -2,2 -2,2 -1,1 -1),(2 -2,2 -3,3 -3,3 -2,2 -2)))")
20:28:35     4. cu_raster_geometry.c:335  - CU_ASSERT_STRING_EQUAL(wkt,"MULTIPOLYGON(((1 -1,1 0,5 0,5 -5,4 -5,0 -5,0 -1,1 -1),(1 -1,1 -2,2 -2,2 -1,1 -1),(2 -2,2 -3,3 -3,3 -2,2 -2),(3 -3,3 -4,4 -4,4 -3,3 -3)))")
20:28:35     5. cu_raster_geometry.c:363  - CU_ASSERT_STRING_EQUAL(wkt,"MULTIPOLYGON(((1 -4,2 -4,2 -3,3 -3,3 -4,4 -4,4 -5,3 -5,1 -5,1 -4)),((1 -4,0 -4,0 -1,1 -1,1 -2,2 -2,2 -3,1 -3,1 -4)),((3 -2,4 -2,4 -1,5 -1,5 -4,4 -4,4 -3,3 -3,3 -2)),((3 -2,2 -2,2 -1,1 -1,1 0,4 0,4 -1,3 -1,3 -2)))")

Change History (14)

comment:1 Changed 6 months ago by robe

Component: rasterbuildbots
Description: modified (diff)
Owner: changed from Bborie Park to robe

comment:2 Changed 6 months ago by robe

Description: modified (diff)
Summary: Debbie failing regress on gdal_polygonize on GDAL 3.2 and 3.1Debbie failing regress raster on gdal_polygonize and raster_surface on GDAL 3.2 and 3.1

comment:3 Changed 6 months ago by robe

Okay I was mistaken. GDAL 3.1 branch is fine. Just GDAL_Master (upcoming 3.2). I think that rules out Proj since both are Proj 7.0

22:00:15  -------------- Dependencies -------------- 
22:00:15   GEOS config:          /var/lib/jenkins/workspace/geos/rel-3.9w64/bin/geos-config
22:00:15   GEOS version:         3.9.0dev
22:00:15   GDAL config:          /var/lib/jenkins/workspace/gdal/rel-3.1w64/bin/gdal-config
22:00:15   GDAL version:         3.1.2
22:00:15   SFCGAL config:        /usr/bin/sfcgal-config
22:00:15   SFCGAL version:       1.3.7
22:00:15   PostgreSQL config:    /var/lib/jenkins/workspace/pg/rel/pg12w64/bin/pg_config
22:00:15   PostgreSQL version:   PostgreSQL 12.3
22:00:15   PROJ4 version:        71
22:00:15   Libxml2 config:       /usr/bin/xml2-config
22:00:15   Libxml2 version:      2.9.10
22:00:15   JSON-C support:       yes
22:00:15   protobuf support:     yes
22:00:15   protobuf-c version:   1003003
22:00:15   PCRE support:         no
22:00:15   Perl:                 /usr/bin/perl
22:00:15   Wagyu:                yes

comment:4 Changed 6 months ago by robe

Summary: Debbie failing regress raster on gdal_polygonize and raster_surface on GDAL 3.2 and 3.1Debbie failing regress raster on gdal_polygonize and raster_surface on GDAL 3.2 (GDAL Master)

comment:6 Changed 6 months ago by robe

Description: modified (diff)

comment:7 Changed 6 months ago by Regina Obe <lr@…>

In 58afcd1/git:

Fix raster regression for GDAL 3.2, polygonize behavior change. Use area and ST_Equals for compare instead of wkt equality. References #4734 for PostGIS 3.1

comment:8 Changed 6 months ago by Regina Obe <lr@…>

In 8e4f510/git:

Fix raster regression for GDAL 3.2, polygonize behavior change. Use area and ST_Equals for compare instead of wkt equality. References #4734 for PostGIS 3.0

comment:9 Changed 6 months ago by robe

Component: buildbotsraster
Milestone: PostGIS GDALPostGIS 2.5.5
Priority: mediumblocker
Summary: Debbie failing regress raster on gdal_polygonize and raster_surface on GDAL 3.2 (GDAL Master)regress raster on gdal_polygonize and raster_surface on GDAL 3.2 (GDAL Master)

comment:10 Changed 6 months ago by Regina Obe <lr@…>

Resolution: fixed
Status: newclosed

In 9d3a207/git:

Fix raster regression for GDAL 3.2, polygonize behavior change. Use area and ST_Equals for compare instead of wkt equality. Closes #4734 for PostGIS 2.5.5

comment:11 Changed 6 months ago by Regina Obe <lr@…>

In 98c1cb2a/git:

Get rid of unused wkt variable - causing gittie to fail. References #4734 for PostGIS 3.1.0

comment:12 Changed 6 months ago by Regina Obe <lr@…>

In b89a6f04/git:

Get rid of unused wkt function and const - quieting more gittie complaints. References #4734 for PostGIS 3.1.0

comment:13 Changed 6 months ago by Regina Obe <lr@…>

In 6dc7c14/git:

Get rid of more const - quieting more gittie complaints. References #4734 for PostGIS 3.1.0

comment:14 Changed 6 months ago by Regina Obe <lr@…>

In 134d865/git:

Get rid of more const, unused variables - quieting more gittie complaints. References #4734 for PostGIS 3.0.2

Note: See TracTickets for help on using tickets.