Opened 5 years ago

Closed 4 years ago

#4586 closed defect (fixed)

FreeBSD erroring on compile both 32-bit and 64-bit

Reported by: robe Owned by: komzpa
Priority: medium Milestone: PostGIS 3.1.0
Component: build Version: master
Keywords: FreeBSD Cc:

Description

05:27:49 /usr/bin/ld: error: undefined symbol: rtdealloc
05:27:49 >>> referenced by raster2pgsql.c:2426
05:27:49 >>>               lto.tmp:(main)
05:27:49 
05:27:49 /usr/bin/ld: error: undefined symbol: rtdealloc
05:27:49 >>> referenced by raster2pgsql.c:2428
05:27:49 >>>               lto.tmp:(main)
05:27:49 
05:27:49 /usr/bin/ld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors)
05:27:49 cc: error: linker command failed with exit code 1 (use -v to see invocation)
05:27:49 gmake[3]: *** [Makefile:84: raster2pgsql] Error 1

This seems to have started around Nov 12th Before that it was another error.

19:54:51 +UNEXPECTED|POSTGIS="3.1.0dev rdf05ab9" [EXTENSION] PGSQL="110" GEOS="3.7.2-CAPI-1.11.2 b55d2125" PROJ="6.1.1" LIBXML="2.9.9" LIBJSON="0.13.1" LIBPROTOBUF="1.3.2" WAGYU="0.4.3 (Internal)" (core procs from "3.1.0dev POSTGIS_REVISION" need upgrade)

I'm going to do a complete uninstall of postgis to make sure it's not caused by a stale build.

Change History (5)

comment:1 by Algunenano, 5 years ago

Introduced by #4574

comment:2 by Algunenano, 5 years ago

Owner: changed from strk to komzpa

comment:3 by robe, 5 years ago

Okay will close this out as soon as #4574 is resolved. Sorry for ignoring you Raul :(

comment:4 by Algunenano, 5 years ago

LTO is fixed after the revert. The UNEXPECTED error is still there but I don't know why. I think robe already did a clean build but it didn't fix it.

comment:5 by Algunenano, 4 years ago

Resolution: fixed
Status: newclosed

Fixed at some point

Note: See TracTickets for help on using tickets.