Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3749 closed enhancement (fixed)

ST_AsMVT support parsing keys/values from a jsonb column

Reported by: Björn Harrtell Owned by: Björn Harrtell
Priority: medium Milestone: PostGIS 2.4.0
Component: postgis Version: trunk
Keywords: Cc:

Description


Change History (10)

comment:1 Changed 2 years ago by Björn Harrtell

In 15385:

ST_AsMVT parse JSONB into keys/values
References #3749

comment:2 Changed 2 years ago by Björn Harrtell

Summary: ST_AsMVT optionally support parsing key/values from a jsonb columnST_AsMVT support parsing keys/values from a jsonb column

comment:3 Changed 2 years ago by Björn Harrtell

Remaining tasks:

  • Document this feature
  • Make it conditionally included for PG 9.4+
Last edited 2 years ago by Björn Harrtell (previous) (diff)

comment:4 Changed 2 years ago by strk

Build fails on Drone due to: "fatal error: utils/jsonb.h: No such file or directory" See https://drone.osgeo.org/postgis/postgis/38

comment:5 Changed 2 years ago by strk

Fails on my dev machine (Ubuntu 16.04.2 LTS) with the same error.

comment:6 Changed 2 years ago by Björn Harrtell

I thought this was because PG < 9.4 and intend to make this feature conditional. Does it look like there might be another reason for the fail?

comment:7 Changed 2 years ago by robe

I think it's the 9.3 issue.

I see dronie is running:

PostgreSQL version: PostgreSQL 9.3.13

I suspect strk is running an antiquated version of PostgreSQL as well.

I'm rerunning debbie and winnie. They too were failing with 9.3 (with same error) but then they got an unrelated error which might just be an issue with simulatneous runs of other things or a memory leak crashing their postgres instance.

comment:8 Changed 2 years ago by Björn Harrtell

Resolution: fixed
Status: assignedclosed

In 15387:

ST_AsMVT JSONB support and regression tests conditional on PG >= 94
Fixes #3749

comment:9 Changed 2 years ago by Björn Harrtell

In 15389:

ST_AsMVT Normalize output to make sure it will be identical regardless of GEOS version
References #3749

comment:10 Changed 2 years ago by Björn Harrtell

In 15390:

ST_AsMVT Document JSONB support
References #3749

Note: See TracTickets for help on using tickets.