Opened 3 years ago

Closed 3 years ago

#3681 closed defect (invalid)

Upgrading PostGIS on Debian6

Reported by: AcidS76 Owned by: pramsey
Priority: medium Milestone: PostGIS 2.0.8
Component: postgis Version: 2.0.x
Keywords: Cc:

Description

Good evening, i'm trying to upgrade PostGis? running on Debian 6 server from 1.5 to 2.0.7, following this guide: https://trac.osgeo.org/postgis/wiki/UsersWikiPostGIS20Debian60src

I downloaded and built all but when i request the version, i see this:

Postgres says: psql (9.3.11, server 8.4.22lts6)

postgres=# SELECT postgis_full_version(); postgis_full_version


POSTGIS="1.5.1" GEOS="3.3.9-CAPI-1.7.9" PROJ="Rel. 4.7.1, 23 September 2009" LIBXML="2.7.7" USE_STATS

I know these versions are out of dated and surely unsupported but i try everything before losing hopes. I would like to upgrade Postgres to the latest version but i fear it's not possible... Could anyone help me? Thanks

Change History (1)

comment:1 Changed 3 years ago by robe

Resolution: invalid
Status: newclosed

This appears to be a user question, not a bug issue.

Please use our mailing list instead - https://lists.osgeo.org/mailman/listinfo/postgis-users

1) Going from PostGIS 1.5 to PostGIS 2.0 requires a hard upgrade of the database. You can't just upgrade an existing database from 1.5 to 2.0. 2.0 to 2.+ however you can do with a soft upgrade using ALTER EXTENSION postgis UPDATE; from within the database.

http://postgis.net/docs/manual-2.3/postgis_installation.html#hard_upgrade

2) I'm guessing you now have both PostGIS 1.5 and PostGIS 2.0 installed. If you create a new database, you will probably get PostGIS 2.0 in that database.

3) If you are compiling from source anyway, I would say to not bother with PostGIS 2.0 and go to PostGIS 2.3. Going from PostGIS 1.5 to PostGIS 2.3 is the same amount of effort as going from PostGIS 1.5 to PostGIS 2.0.

Note: See TracTickets for help on using tickets.