Opened 3 years ago

Closed 3 years ago

#3649 closed defect (fixed)

knn_recheck regress failing under PostgreSQL 10 devel

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.3.3
Component: postgis Version: master
Keywords: postgresql 10 Cc:

Description (last modified by robe)

Debbie's 10 develop jobs have been failing on knn_recheck regress

knn_recheck .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_3_pg10.0w64/test_94_diff)
-----------------------------------------------------------------------------
--- knn_recheck_expected	2016-06-07 22:02:08.819804960 +0000
+++ /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_3_pg10.0w64/test_94_out	2016-09-29 04:04:30.003485948 +0000
@@ -13,8 +13,8 @@
 #3|1|147|9.6598|9.6598
 #3|1|291|10.8780|10.8780
 #3|1|292|13.4929|13.4929
-#3|500003|500004|1447.7424|1447.7424
 #3|500003|500002|1447.7424|1447.7424
+#3|500003|500004|1447.7424|1447.7424
 #3|500003|500001|3423.4486|3423.4486
 #3|500003|500005|3423.4486|3423.4486
 #3|500003|22837|5123.7770|5123.7770
@@ -59,7 +59,7 @@
 #2g|30695|21264.3654|21264.3654
 #2g|30512|25313.2118|25313.2118
 #3g|1000|t
-#3g|2614|t
+#3g|2614|f
 #3g|500000|t
 #1g|500000|0.0000|0.0000
 #1g|600003|69974.6935|69974.6935
@@ -72,7 +72,7 @@
 #2g|30695|21264.3654|21264.3654
 #2g|30512|25313.2118|25313.2118
 #3g|1000|t
-#3g|2614|t
+#3g|2614|f
 #3g|500000|t
 #1nd-3|290|260.6797|260.6797
 #1nd-3|287|264.3000|264.3000
@@ -89,10 +89,10 @@
 #3nd-3|1|294|9.6598|9.6598
 #3nd-3|1|582|10.8780|10.8780
 #3nd-3|1|583|13.4929|13.4929
-#3nd-3|500003|500004|1448.3262|1448.3262
 #3nd-3|500003|500002|1448.3262|1448.3262
-#3nd-3|500003|500001|3424.9088|3424.9088
+#3nd-3|500003|500004|1448.3262|1448.3262
 #3nd-3|500003|500005|3424.9088|3424.9088
+#3nd-3|500003|500001|3424.9088|3424.9088
 #3nd-3|500003|45674|5153.7747|5153.7747
 #3nd-3|600001|600002|0.0000|0.0000
 #3nd-3|600001|9752|54.2730|54.2730
-----------------------------------------------------------------------------

I'm not sure which PostgreSQL commit this started happening in, since I don't keep logs that far back. At the very least since Sept 22nd.

I'm going to revisit this time permitting since 10.0 is a year's off so might be resolved by then.

Change History (6)

comment:1 Changed 3 years ago by robe

Description: modified (diff)

comment:2 Changed 3 years ago by robe

Keywords: postgresql 10 added
Version: 2.2.x2.3.x

comment:3 Changed 3 years ago by robe

Version: 2.3.xtrunk

Okay just checked on PostgreSQL recheck and looks like it's still an issue. I was hoping it would resolve itself or latest change to box2df_distance would resolve things, but alas still an issue.

Last run which occurred after pramsey r15283 patch to fix #3418 looks like this:

https://debbie.postgis.net/view/PostGIS/job/PostGIS_Regress_PGDEV_Weekly/3004/consoleFull

PostgreSQL 10devel on x86_64-pc-linux-gnu, compiled by gcc (Debian 5.2.1-22) 5.2.1 20151010, 64-bit
  Postgis 2.4.0dev - r15283 - 2017-01-06 22:04:03
  scripts 2.4.0dev r15283
  GEOS: 3.6.2dev-CAPI-1.10.2 r4324
  PROJ: Rel. 4.9.2, 08 September 2015
  SFCGAL: 1.3.0

 knn_recheck .. failed (diff expected obtained: /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_4_pg10.0w64/test_94_diff)
-----------------------------------------------------------------------------
--- knn_recheck_expected	2017-01-01 03:28:18.511591903 +0000
+++ /var/lib/jenkins/workspace/postgis/regress_pgdev/tmp/2_4_pg10.0w64/test_94_out	2017-01-06 22:07:03.409251996 +0000
@@ -13,8 +13,8 @@
 #3|1|147|9.6598|9.6598
 #3|1|291|10.8780|10.8780
 #3|1|292|13.4929|13.4929
-#3|500003|500004|1447.7424|1447.7424
 #3|500003|500002|1447.7424|1447.7424
+#3|500003|500004|1447.7424|1447.7424
 #3|500003|500001|3423.4486|3423.4486
 #3|500003|500005|3423.4486|3423.4486
 #3|500003|22837|5123.7770|5123.7770
@@ -59,7 +59,7 @@
 #2g|30695|21264.3654|21264.3654
 #2g|30512|25313.2118|25313.2118
 #3g|1000|t
-#3g|2614|t
+#3g|2614|f
 #3g|500000|t
 #1g|500000|0.0000|0.0000
 #1g|600003|69974.6935|69974.6935
@@ -72,7 +72,7 @@
 #2g|30695|21264.3654|21264.3654
 #2g|30512|25313.2118|25313.2118
 #3g|1000|t
-#3g|2614|t
+#3g|2614|f
 #3g|500000|t
 #1nd-3|290|260.6797|260.6797
 #1nd-3|287|264.3000|264.3000
@@ -89,10 +89,10 @@
 #3nd-3|1|294|9.6598|9.6598
 #3nd-3|1|582|10.8780|10.8780
 #3nd-3|1|583|13.4929|13.4929
-#3nd-3|500003|500004|1448.3262|1448.3262
 #3nd-3|500003|500002|1448.3262|1448.3262
-#3nd-3|500003|500001|3424.9088|3424.9088
+#3nd-3|500003|500004|1448.3262|1448.3262
 #3nd-3|500003|500005|3424.9088|3424.9088
+#3nd-3|500003|500001|3424.9088|3424.9088
 #3nd-3|500003|45674|5153.7747|5153.7747
 #3nd-3|600001|600002|0.0000|0.0000
 #3nd-3|600001|9752|54.2730|54.2730
-----------------------------------------------------------------------------

so no change as far as I can see. We'll probably have to start investigating if the issue is on our end or the PostgreSQL 10 code end since 10 will be out in another 7 months or so.

comment:4 Changed 3 years ago by robe

Milestone: PostGIS 2.4.0PostGIS 2.3.3
Owner: changed from pramsey to robe

This looks to be all caused by records that have the same distance but the one chosen to be first is different in PostgreSQL 10. I should probably fix for 2.3 as well, since it's more a bug in the regress test than anything to do with PostgreSQL version.

Reworking the examples and will commit new test to both 2.3 and 2.4

comment:5 Changed 3 years ago by robe

In 15348:

Get rid of knn tests where multiple records have the same distances
references #3649 for 2.3

comment:6 Changed 3 years ago by robe

Resolution: fixed
Status: newclosed

In 15349:

Get rid of knn tests where multiple records have the same distances
closes #3649 for 2.4

Note: See TracTickets for help on using tickets.