Opened 3 years ago

Closed 6 weeks ago

#3603 closed enhancement (fixed)

use pkg-config more

Reported by: gdt Owned by: strk
Priority: medium Milestone: PostGIS 3.0.0
Component: build/upgrade/install Version: trunk
Keywords: Cc:

Description

configure looks for json-c in a directory specified on the command line, which is gratuitously hard because json-c supports pkg-config. Ideally, packages known to use pkg-config should be found that way; both proj and json-c have pkg-config entries, and probably all non-ancient versions of them do. This would also really simply configure.ac.

I am unclear on milestone; seems likely not for 2.3 given imminent release notion, but would be on the list for afterwards.

Change History (4)

comment:1 Changed 3 years ago by robe

Milestone: PostGIS 2.3.0PostGIS 2.4.0

comment:2 Changed 2 years ago by robe

Milestone: PostGIS 2.4.0PostGIS 2.5.0

Well I think we have an issue in that pkg-config is technically not required by our configure. Though the introduction of ST_ASMVT in 2.4 makes it required to build the MVT stuff. I'm tempted to punt this one though to 2.5.

pramsey if you can squeeze this in on your other check feel free to do so and push back.

comment:3 Changed 12 months ago by komzpa

Milestone: PostGIS 2.5.0PostGIS 3.0.0

comment:4 Changed 6 weeks ago by Algunenano

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.