Opened 11 years ago

Closed 11 years ago

#359 closed defect (fixed)

Issue with gui when loading some files

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 1.5.0
Component: postgis Version: master
Keywords: Cc:

Description

I think I may have experienced one of the issues Nicklas is running into.

I just tried to load this file http://www2.census.gov/geo/tiger/TIGER2009/tl_2009_us_state.zip

(into new geography type also same issue with geometry type)

I saw a error fly by and then the width of the shapefile dialog exploded between my 2 30 in split screens to take up the width of my two screens. I presume to fit the failed error and had cryptic
in all the fields.

Though it does this in both stand-alone and via Pgadmin.

I haven't tried loading that above file using the commandline to see what error it is registering if any.

Change History (12)

comment:1 Changed 11 years ago by mcayland

I found some initialisation bugs in the GUI which are now fixed in SVN (at least, it seems to work with the above file). Please can you test and try again.

There does seem to be a problem with the length of a line in GTK though; if you re-run the file but tick the "disable big integers" options it seems that GTK crashes due to the long SQL lines. I'm wondering if perhaps we should consider truncating them at 255 characters or so?

comment:2 Changed 11 years ago by pramsey

Sounds reasonable to me. Likely the cause of the "take up the whole screen" bug too?

comment:3 Changed 11 years ago by robe

Milestone: PostGIS 1.5.0
Version: trunk

Mark,

It works on my XP box for this data set, though I was testing on my Windows 7.

Nicklas -- if you are still having problems compiling, I put up a fresh copy up http://www.postgis.org/download/windows/extras/postgisgui_pgadmin-1.5svn.zip

Complete with Windows theming that Paul whined about. Though I don't like the windows theme much more than the non-themed so it seems a nuisance to package all those extra files to get the windows theme unless I missed something. I see a difference but not much. Can we have a different theme maybe like some sort of PostGIS theme :).

comment:4 Changed 11 years ago by robe

Owner: changed from pramsey to robe
Status: newassigned

comment:5 Changed 11 years ago by robe

I think you introduced another bug. The new version is defaulted to preserve case. This should be unchecked. Now my default import (unless I uncheck the preserve case) is coming in like QGIS SPIT (all upper case). Annoying.

comment:6 Changed 11 years ago by mcayland

I've just added an extra couple of missing defaults to SVN trunk (basically any uninitialised values will just be set to random values on startup). Please can yourself and Nicklas try again and see that this solves everything for you? The only thing that is missing is to use a shortened length for failed SQL statements, and perhaps change the default to COPY rather than INSERT for the GUI (there is a section in main() where the defaults can be overridden).

Tomorrow I'll be back at home and so will be able to spend a bit more time looking at a sensible solution to #311.

comment:7 Changed 11 years ago by nicklas

Now the default for empty records policy is 1. Is that right?

Otherwise it seems to work exept for that shape filter in filedialog and that make install doesn't install shp2pgsql-gui.exe

comment:8 Changed 11 years ago by pramsey

I've added the GUI as an install target at r5057

comment:9 Changed 11 years ago by mcayland

Yeah, I've tried my best to standardise the defaults across both the GUI and CLI versions of the loader where possible.

I've just applied a patch to truncate any SQL statements that throw an error to 255 characters which stops GTK crashing but still extends the window when an error is thrown. I think this is due to the layout manager being used for the dialog, but I'll defer to Paul on this one.

In terms of the shape filter, I've applied another patch to give the filter a name but I'm not sure that this is the problem you are seeing. Can you try again from SVN, and if it is still broken attach a screenshot to this bug?

comment:10 Changed 11 years ago by nicklas

Mark Great, now it works :-) It even keeps thefilder from where a closed the file dialog, that's good. And the shape file filter works.

Paul Yes, now it installs too

One thing I discoverd now. If I close the options window with the cross in the corner, it won't open next time I try, so I have to restart the loader gui. Since there is no other "cancel" button, I think closing with the cross should be a valid way of closing the window.

and just a question. this "Policy for records with empty (null) values". What does it mean. Is "1" some code, if so, meaning what?

/Nicklas

comment:11 Changed 11 years ago by pramsey

I have attempted a fix to the expanding window problem, but since it doesn't manifest in OS/X I haven't debugged in Win32 yet. (r5060)

comment:12 Changed 11 years ago by pramsey

Resolution: fixed
Status: assignedclosed

Remaining issues ticketed (separately!!) in #363 and #364.

Note: See TracTickets for help on using tickets.