Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#356 closed defect (fixed)

Get rid of logging of password in shp2pgsql-gui

Reported by: robe Owned by: pramsey
Priority: medium Milestone: PostGIS 1.5.0
Component: postgis Version: master
Keywords: Cc:

Description

This is a minor gripe, but can we not log passwords on the logging window. It is particularly annoying if you are trying to do a demo.

Attachments (1)

guishot.png (20.8 KB) - added by robe 11 years ago.
Okay here it is -- I have already changed my password

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by pramsey

Can you post a screenshot? This doesn't ring any bells with me.

Changed 11 years ago by robe

Attachment: guishot.png added

Okay here it is -- I have already changed my password

comment:2 Changed 11 years ago by pramsey

Resolution: fixed
Status: newclosed

Awesome, I totally rock. Good catch, replaced with a sanitized version at r5052.

comment:3 Changed 11 years ago by robe

Resolution: fixed
Status: closedreopened

I think you missed a spot. I see asterisks now when I do test connection, but when I do import, I still see my unsanitized password on the first line of import.

comment:4 Changed 11 years ago by pramsey

Resolution: fixed
Status: reopenedclosed

Merry Christmas! r5054

comment:5 Changed 11 years ago by robe

Resolution: fixed
Status: closedreopened

Only seems to do it when I click test connection. I thought we had fixed it before but seems to be an issue again.

comment:6 Changed 11 years ago by pramsey

Resolution: fixed
Status: reopenedclosed

Yeah, I'm sure we had this fixed. I'm going to trace back and see if/how it got changed again. Anyhow, fixed (again?) at r5095

comment:7 Changed 11 years ago by pramsey

Looking back, I broke the connection test case when I fixed actual import run case. I guess we just didn't notice it at the time.

Note: See TracTickets for help on using tickets.