Opened 11 years ago

Closed 11 years ago

#326 closed defect (fixed)

pgsql2shp field mappings not perfect

Reported by: pramsey Owned by: mcayland
Priority: medium Milestone: PostGIS 1.5.0
Component: postgis Version: master
Keywords: Cc: peter.hopfgartner@…

Description

From postgis-users and Peter Hopfgartner http://postgis.refractions.net/pipermail/postgis-users/2009-November/025285.html

since we right in the middle of comparing interoperability of shape files between some FOSS programs and ArcGIS, we encoutered also the following:

gvSIG chokes on the Bigint as produced by pgsql2shp. Looking at ArcGIs generated files, the max length for numbers is 19, compared to 20 for integers and 32 for floating points as in pgsql2shp. This seems to be confirmed by some Borland tools, when configured for dBase III+.

Another limit seems to be that of text fields, that must be no longer then 254. This is the maximum as given by ArcGIS and by the Borland tool.

Another point is Boolean: ArcGIS seems to not allow the creation of boolean fields and the Borland Tool ("Database Desktop") says that Booleans have a length of 1.

Change History (2)

comment:1 Changed 11 years ago by pramsey

Changed MAX_DBF_FIELD_SIZE to 254 at r5009

comment:2 Changed 11 years ago by pramsey

Resolution: fixed
Status: newclosed

Reduced int8 width to 19 at r5031.

Note: See TracTickets for help on using tickets.