Opened 5 years ago

Closed 3 years ago

#3112 closed enhancement (wontfix)

Add a new function to determine if a geometry will be accepted by routines not handling curve geometries

Reported by: aaime Owned by: pramsey
Priority: low Milestone: PostGIS 2.4.0
Component: postgis Version: 2.1.x
Keywords: Cc:

Description

ST_HasArc almost does the job, but will return "false" on a curve geometry that does not contain any circular segment (e.g., a compound curve that only contains straight segments).

Please add a new function to determine if a geometry is safe to use with "non curve aware" functions (regardless of its circular segment contents)

Change History (6)

comment:1 Changed 5 years ago by strk

could be done by only looking at GeometryType? output (recursively checking within GEOMETRYCOLLECTION, which does allow for internal curves)

comment:2 Changed 5 years ago by robe

Milestone: PostGIS 2.1.8PostGIS 2.2.0
Priority: mediumlow

comment:3 Changed 5 years ago by pramsey

The problem is not so much in categorizing whether a geometry has curves in them as in categorizing which functions do or do not handle curved geometries. It might be better just to do a run through the whole functional set and pushing all arc's through stroking so that we have no functions that do not "support" curved geometry. If that results in a little weirdness (the first stop in running simplify on an arced object would be adding a bunch of vertices to it) at least we'd have 100% functional coverage for those types.

comment:4 Changed 5 years ago by pramsey

Milestone: PostGIS 2.2.0PostGIS 2.3.0

I think I'd rather move to more universally stroking all arc features and just feeding them through rather than trying to flag/error them.

comment:5 Changed 4 years ago by robe

Milestone: PostGIS 2.3.0PostGIS 2.4.0

comment:6 Changed 3 years ago by robe

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.