Opened 8 years ago

Closed 8 years ago

#2999 closed defect (invalid)

recipe for target 'shp2pgsql' failed

Reported by: martin5519 Owned by: pramsey
Priority: high Milestone: PostGIS 2.1.5
Component: postgis Version: 2.1.x
Keywords: Cc:

Description

Hello,

Seems to be similar issue to #2727. Platform and installed dependencies are as follows. Trying to install Postgis21 from Freebsd Ports package.

Freebsd 10.1 Postgresql 9.2 json-c-0.12_1 geos-3.4.2_2 proj-4.8.0_3

I run 'make' and get the following for Postgis21:

../liblwgeom/.libs/liblwgeom.so: undefined reference to `geos::geom::GeometryFactory::createMultiPolygon() const' cc: error: linker command failed with exit code 1 (use -v to see invocation) Makefile:103: recipe for target 'shp2pgsql' failed gmake[4]: * [shp2pgsql] Error 1 gmake[4]: Leaving directory '/usr/ports/databases/postgis21/work/postgis-2.1.3/loader' GNUmakefile:14: recipe for target 'all' failed

I tried with Postgis20 but get the following:

Makefile:90: recipe for target 'shp2pgsql-core.o' failed gmake[4]: * [shp2pgsql-core.o] Error 1

Any help would be appreciated and will donate. I did try to remove references to shp2pgsql in the Makefile as I don't think we will be using this but still did not work - same error.

Martin

Change History (2)

comment:1 by martin5519, 8 years ago

Hello,

IN short, 2.0 and 2.1.3 will fail because shp2pgsql gmake fails. I downloaded 2.1.4 from the Postgis website and installed from source. I got the exact same error.

Martin

comment:2 by pramsey, 8 years ago

Resolution: invalid
Status: newclosed

Since this is a ports problem, not a PostGIS problem, all we can offer is advice. (And this is probably a problem with your system, not with ports). The error is liblwgeom not finding a function in libgeos which indicates a version mismatch between what geos liblwgeom is expecting and what you have. Probably you have a correct version of libgeos in your ports, but an old version you hand-installed lying around somewhere else. The hand-installed one is being found before your ports version, and you're getting an error.

Note: See TracTickets for help on using tickets.