Opened 8 years ago

Closed 8 years ago

#2945 closed defect (fixed)

ST_ClipByBox2D raises an exception with unclosed polygon rings input

Reported by: strk Owned by: pramsey
Priority: blocker Milestone: PostGIS 2.2.0
Component: postgis Version: master
Keywords: Cc:

Description

By contract ST_ClipByBox2D should never raise an exception. It does when fed polygons with unclosed rings. The problem is that the function is implemented in GEOS so the input geometry must be "convertible" even if not topologically valid.

I think the quickest way to fix this would be to add an optional parameter in the postgis-to-geos converter to allow automatically "fixing enough for geos to be happy" those geometries. There's code for that in the ST_MakeValid code path…

Change History (1)

comment:1 by strk, 8 years ago

Resolution: fixed
Status: newclosed

Fixed by r13018

Note: See TracTickets for help on using tickets.