Opened 11 years ago

Closed 11 years ago

#293 closed defect (fixed)

[wktraster] Missed config.guess and config.sub after autogen.sh exec

Reported by: jorgearevalo Owned by: pracine
Priority: medium Milestone: WKTRaster 0.1.6
Component: raster Version: master
Keywords: Cc:

Description (last modified by mloskot)

In revision r4776, after executing ./autogen.sh, files config.guess and config.sub are deleted. I had to execute svn update to restore them from repository and then execute ./configure.

Change History (11)

comment:1 Changed 11 years ago by mloskot

Status: newassigned

comment:2 Changed 11 years ago by mloskot

Description: modified (diff)

Jorge,

I can not reproduce your problem. I tried to do it this way:

  • Update and check if reported files are present
    mloskot@dog:~/dev/wktraster/_svn/trunk$ svn update
    At revision 4777.
    mloskot@dog:~/dev/wktraster/_svn/trunk$ svn st
    mloskot@dog:~/dev/wktraster/_svn/trunk$ ls config.*
    config.guess  config.sub
    
  • Run ./autogen.sh
    mloskot@dog:~/dev/wktraster/_svn/trunk$ ./autogen.sh 
    * Running /usr/bin/libtoolize (2.2.6)
    	OPTIONS = --force --copy
    libtoolize: putting auxiliary files in `.'.
    libtoolize: copying file `./ltmain.sh'
    libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `macros'.
    libtoolize: copying file `macros/libtool.m4'
    libtoolize: copying file `macros/ltoptions.m4'
    libtoolize: copying file `macros/ltsugar.m4'
    libtoolize: copying file `macros/ltversion.m4'
    libtoolize: copying file `macros/lt~obsolete.m4'
    libtoolize: Consider adding `-I macros' to ACLOCAL_AMFLAGS in Makefile.am.
    * Running /usr/bin/aclocal (1.11)
    * Running /usr/bin/autoconf (2.64)
    * Running /usr/bin/autoheader (2.64)
    ======================================
    Now you are ready to run './configure'
    ======================================
    
  • Check if reported files are still present
    mloskot@dog:~/dev/wktraster/_svn/trunk$ ls config.*
    config.guess  config.sub
    
  • Check if anything has changed, e.g. reported files have been touched or any other files removed
    mloskot@dog:~/dev/wktraster/_svn/trunk$ svn st
    mloskot@dog:~/dev/wktraster/_svn/trunk$ svn up
    At revision 4777.
    mloskot@dog:~/dev/wktraster/_svn/trunk$
    
  • Check if ./configure can be executed
    mloskot@dog:~/dev/wktraster/_svn/trunk$ ./configure
    checking build system type... x86_64-unknown-linux-gnu
    checking host system type... x86_64-unknown-linux-gnu
    checking for gcc... gcc
    checking for C compiler default output file name... ^C
    mloskot@dog:~/dev/wktraster/_svn/trunk$ 
    

As you see, it works as expected for me.

Environment:

  • Linux 64-bit (Ubuntu 9.10)
  • GCC 4.4.1
  • Autotools as installed by default using Ubuntu 9.10 packages

comment:3 Changed 11 years ago by mloskot

Summary: Missed config.guess and config.sub after autogen.sh exec[wktraster] Missed config.guess and config.sub after autogen.sh exec

comment:4 Changed 11 years ago by pracine

I have the exact same problem under MinGW... You have to build from a virgin copy of the source.

comment:5 Changed 11 years ago by mloskot

Owner: mloskot deleted
Status: assignednew

I don't use MinGW and I can't test it. It looks like MinGW problem, because it works perfectly well in native Unix environment.

comment:6 Changed 11 years ago by jorgearevalo

I tested this in two Unix enviroments (Ubuntu both). In one worked fine, in another one I had the original error. Today I could execute ./configure without problems in one of the enviroments. I'm going to test in the other one.

comment:7 Changed 11 years ago by pracine

Owner: set to pracine

comment:8 Changed 11 years ago by mloskot

The "two Unix environments (Ubuntu both)" does not tell much. The two versions of Linux you use may be significantly different environments with different versions of autotools.

comment:9 Changed 11 years ago by jorgearevalo

Yes, sorry. I didn't have access to the other enviroment. Today, I'll check it. Just now I tested in Ubuntu 9.10 with autoconf 2.64, automake 1.11 and libtool 2.2.6. Works.

comment:10 Changed 11 years ago by jorgearevalo

I'm in the other enviroment right now. Ubuntu 9.10 with same versions on autoconf, automake and libtool. It works, of course.

I can't reproduce the error again. Pierre?

comment:11 Changed 11 years ago by pracine

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.