Opened 5 years ago

Closed 5 years ago

#2827 closed defect (fixed)

make check ERROR: unrecognized configuration parameter "postgis.backend"

Reported by: strk Owned by: strk
Priority: medium Milestone:
Component: postgis Version: master
Keywords: sfcgal Cc: vmora, robe

Description

Running

make check RUNTESTFLAGS='-v --extension --upgrade-path=2.0.5--2.2.0dev'

I get the error:

--- sfcgal/concave_hull_expected        2014-06-25 14:05:55.018274295 +0200
+++ /tmp/pgis_reg/test_105_out  2014-07-08 11:18:09.069767628 +0200
@@ -1,3 +1,4 @@
+ERROR:  unrecognized configuration parameter "postgis.backend"

It sounds like the "postgis.backend" GUC parameter is not installed on upgrade, but only on new install, can it be ?

Change History (8)

comment:1 Changed 5 years ago by strk

This could be related:

Preparing db 'postgis_reg' using: CREATE EXTENSION postgis VERSION '2.0.5'
Upgrading PostGIS in 'postgis_reg' using: ALTER EXTENSION postgis UPDATE TO '2.2.0dev'
ERROR:  function postgis_sfcgal_version() does not exist

comment:2 Changed 5 years ago by strk

It sounds related to #2754

comment:3 Changed 5 years ago by strk

Cc: vmora robe added
Keywords: sfcgal added

Should run_test get a new switch to load the sfcgal script/extension ? like --topology is used for topology ?

comment:4 Changed 5 years ago by strk

Summary: After 2.0.5 to 2.2.0dev upgrade: ERROR: unrecognized configuration parameter "postgis.backend"make check ERROR: unrecognized configuration parameter "postgis.backend"

r12766 fixes the support for --extension and sfcgal switch, fixing the "postgis_sfcgal_version" availability during testing.

But still, the 'unrecognized configuration parameter "postgis.backend"' comes out on make check (no matter upgrade switches)

comment:5 Changed 5 years ago by strk

NOTE: this is when running against 9.1.13, so could be that at that time the database needs to be instructed to recognize the GUC (likely).

comment:6 Changed 5 years ago by strk

Confirmed, it's about 9.1.x needing an explicit configuration to recognize namespaced GUCs. Not sure how to deal with this at "make check" time. Maybe GUC testing should be disabled for 9.1 ? Or only if custo_variable_classes does not contain "postgis" ?

comment:7 Changed 5 years ago by pramsey

Owner: changed from pramsey to strk

comment:8 Changed 5 years ago by strk

Resolution: fixed
Status: newclosed

I cannot reproduce anymore. Will file a new one if anything else comes out.

Note: See TracTickets for help on using tickets.