Opened 8 years ago

Last modified 14 months ago

#2676 reopened enhancement

Change Debbie to also test extension upgrade

Reported by: robe Owned by: robe
Priority: medium Milestone: Website Management, Bots
Component: buildbots Version: 2.1.x
Keywords: Cc:

Description

Right now none of the bots test the extension upgrade feature strk put in. Going to change that so we have better regression testing and hopefully fewer surprises when we release.

Won't be able to make this change until fix at least issue #2673

Change History (10)

comment:1 Changed 7 years ago by robe

I think I figured out the problem here. It's that liblwgeom that want's to install itself in /usr/local/lib and since I'm running jenkins under an unprivileged account, it can't install there. Do we have a way to compile that statically into postgis.so file. I'd rather not have that file installed in some place since it also makes our tests dependent on one another in unpredictable ways (micros).

In windows it just naturally ends up being statically compiled though it still tries to install include files which is very annoying.

comment:2 Changed 5 years ago by strk

I've added upgrade testing to Dronie, using the new utils/check_all_upgrades.sh -- you may find that script useful for Debbie and Winnie. For liblwgeom install path (which may affect loader/dumper) you may try using --prefix

comment:3 Changed 5 years ago by strk

See #635 if --prefix doesn't work

comment:4 Changed 4 years ago by strk

I've added upgrade testing to Debbie, using utils/check_all_upgrades.sh in ci/debbie/postgis_regress.sh of trunk branch with r16226 - let's see if it works and it can be improved by installing more versions of PostGIS on the machine.

comment:5 Changed 4 years ago by strk

unpackaged--2.5.0dev extension upgrade fails with:

ERROR: extension "postgis_sfcgal" does not exist

See https://debbie.postgis.net/job/PostGIS_Regress/8259/console

Regina: ideas ?

comment:6 Changed 4 years ago by strk

Resolution: fixed
Status: newclosed

It looks like I fixed the "postgis_sfcgal" issue as of r16340 I'm closing this. Reopen if you you see failures related to upgrade testing.

comment:7 Changed 4 years ago by strk

In 16346:

Have Debbie test all available upgrades

References #2676 for 2.4 branch

comment:8 Changed 4 years ago by strk

Resolution: fixed
Status: closedreopened

I'm reopening to backport the testing to older branches.

comment:9 Changed 4 years ago by strk

Although now Debbie also tests upgrades in the 2.4 branch there's effectively no upgrade test being run, probably because there's no system-wide installed PostGIS < 2.4.3 - do you confirm Regina ? See https://debbie.postgis.net/job/PostGIS_Regress/8472/console

comment:10 Changed 14 months ago by robe

Milestone: Management 2.0Website Management, Bots

Milestone renamed

Note: See TracTickets for help on using tickets.