Opened 8 years ago

Closed 8 years ago

#2651 closed defect (fixed)

tickets.sql: function st_envelope(unknown) is not unique

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 2.2.0
Component: build/upgrade/install Version: 2.1.x
Keywords: extension Cc:

Description

When running regress/run_test.pl --extension regress/tickets.sql, 2 errors are raised about non-unique functions taking "unknown" type.

This does NOT happen with non-extension install. I suspect it has to do with CASTs not being installed by the extension mechanism.

NOTE: this should have nothing to do with the regression in extension upgrade (#2560), as it's not happening after upgrade but after initial install.

Robe, can you confirm with any of your 2.1.x installs ?

Change History (4)

comment:1 Changed 8 years ago by strk

Component: postgisbuild/upgrade/install
Owner: changed from pramsey to strk

comment:2 Changed 8 years ago by strk

Keywords: extension added

comment:3 Changed 8 years ago by strk

Sorry, I just realized this is really due to "EXTENSION" always including "raster" while "ticket.sql" is really meant only for postgis, with no raster.

Why, oh why, are postgis and raster in the same extension :(

I guess we could be nice and tweak tickets.sql to be explicit about the datatype... PS: there's no "testsuite" component

comment:4 Changed 8 years ago by strk

Milestone: PostGIS 2.1.2PostGIS 2.2.0
Resolution: fixed
Status: newclosed

Fixed with r12260 in master. Not worth backporting.

Note: See TracTickets for help on using tickets.