Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2513 closed defect (duplicate)

postgis Updation from 2.0 to 2.1

Reported by: rsirimalla Owned by: pramsey
Priority: high Milestone: PostGIS 2.1.1
Component: postgis Version: 2.0.x
Keywords: PostGIS; cannot access Cc: John.Joel@…

Description

As part of applying an OS patch (Linux), there includes upgraded from Postgres 9.1 to 9.2 and PostGIS from 2.0 to 2.1.

Immediately after installing the patch, while trying to access one of our database tables, we received an error message stating "ERROR: could not access file $libdir/postgis-2.0": No such file or directory".

Have you seen this before? Why would a database upgraded with PostGIS 2.1 extensions be trying to access a PostGIS 2.0 function?

Thanks.

Attachments (1)

errormessage.jpg (20.0 KB) - added by rsirimalla 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by rsirimalla

Attachment: errormessage.jpg added

comment:1 Changed 8 years ago by robe

Resolution: duplicate
Status: newclosed

Yes we are aware of this. Happens if the old library is removed. It will be fixed in 2.1.1 source soon to be released.

Please refer to: #2510 for details

comment:2 Changed 8 years ago by robe

One question before I dismiss this as a duplicate -- did you get an error after doing

ALTER EXTENSION postgis ...

From the sounds of this,it sounds like you simply migrated 9.1 to 9.2 without upgrading your database as well.

Your database would still be in 2.0. What you should have done is upgraded your 9.1 instance to 2.1 and then migrated over. Or install 2.0 on 9.2 and then upgraded your db to 2.1

Note: See TracTickets for help on using tickets.