Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#250 closed defect (fixed)

Trunk doesn't compile under MingW because of regex

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 1.5.0
Component: postgis Version: master
Keywords: Cc:

Description

I think I worked around this by putting in some vood in config.ac and the postgis make files to get this to work and not break linux.

My original hardcoding broke my linux because regex is already compiled into gcc or whatever, but is not with MingW.

Will submit to subversion shortly.

Change History (9)

comment:1 Changed 11 years ago by robe

Owner: changed from pramsey to robe
Status: newassigned

Fixed at r4511. I'm going to leave open since I've only tested against OpenSuse? and mingW. Paul, Mark, and Kevin -- can you verify you can still compile.

comment:2 Changed 11 years ago by mcayland

Please don't - the fix for the linker flags is just a quick hack. Mainly because the dependency for regex is actually on liblwgeom and not the .so module for starters...

My vote would be to remove regex from the code totally - it seems too much of an overkill for what we're using it for.

ATB,

Mark.

comment:3 Changed 11 years ago by robe

Mark,

Sorry about that committing without giving you fair warning. Feel free to take it out.

I would rather it stay in if it works fine for all of you until we get a regex replacement since its frustrating to be working on a separate version from everyone else.

comment:4 Changed 11 years ago by mcayland

Okay. As a quick lunchtime project, I've just committed a fix for this to trunk - please can you test?

ATB,

Mark.

comment:5 Changed 11 years ago by robe

Well - I can compile under MingW and it passes the cunit tests, but fails my torture test.

Can't do this anymore: CREATE TABLE pgis_geoggarden (gid serial, the_geog geography(POINT, 4326));

Gives me a "Invalid geometry type modifier: point"

Though I can do this yee pee: CREATE TABLE gtable ( id integer primary key, geog geography );

comment:6 Changed 11 years ago by mcayland

Duh - forgot to bump the array indices on my last commit. Can you "svn up" and try again?

ATB,

Mark.

comment:7 Changed 11 years ago by robe

Resolution: fixed
Status: assignedclosed

Okay that seems to solve the problem and at a cursory glance seems to be able to create the other geography types as well.

So I'll close this out.

comment:8 Changed 11 years ago by robe

From Nicklas' note -- Nick can you give another try -- removed regex.h at r4533

---ORIGINAL NOTE -- Hallo I haven't tried compiling with geography since ticket 250 was closed. I still get the same error-message that regex.h is missing. I see the include of regex.h is still in libgeom.h line 18. Am I missing something in my installation? or am I just missing something... :-) Thanks Nicklas

comment:9 Changed 11 years ago by nicklas

Yes, now it compiles :-)

But I don't have things in place to run make check.

/Nicklas

Note: See TracTickets for help on using tickets.