Opened 11 years ago

Closed 10 years ago

#2476 closed defect (worksforme)

Invalid access to memory location in postgis-2.1.dll (windows 64-bit) 9.3 rc1

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.1.1
Component: raster Version: 2.1.x
Keywords: windows64bit Cc:

Description (last modified by robe)

this is the same error I was getting during install that magically went away. I'm getting this on some raster tables.

"POSTGIS="2.1.1dev r11897" GEOS="3.4.2-CAPI-1.8.2 r3924" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.10.0, released 2013/04/24" LIBXML="2.7.8" LIBJSON="UNKNOWN" RASTER" 

error getting which is only on access to certain raster tables (MA state plane meters)
An error has occurred:

ERROR:  could not load library "C:/Program Files/PostgreSQL/9.3/lib/postgis-2.1.dll": Invalid access to memory location.

What is very bothersome is that I'm only having this issue on my 64-bit windows 7 laptop. I'm going to try a newer build to see if the problem goes away. My windows 7 desktop is running postgis 2.2.0 dev. The tables in question are ones that I couldn't load from file on my laptop because it complained GDAL_DATA was not set though I verified it was set and then on last file for load it would crash raster2pgsql with same message. My next attempt was to restore from my postgis 2.2.0dev build but tables when accessed then gave same message.

Change History (9)

comment:1 by robe, 11 years ago

Component: postgisraster
Description: modified (diff)
Owner: changed from pramsey to Bborie Park

comment:2 by robe, 11 years ago

Owner: changed from Bborie Park to robe

comment:3 by robe, 11 years ago

Description: modified (diff)

comment:4 by robe, 11 years ago

I guessing this is some sort of permission problem to the gdal-data folder I have since it only happens with the georeferenced raster table I have and not with the dog picture table I have. The main difference between my laptop and desktop is the laptop was installed using windows edb installer and my desktop I just use the binaries and start and stop as needed so I think the desktop one runs under my account context and the installer one runs under network service account.

I still need to copy over latest binaries again to rule that out and test on my server one again and check the permissions on the server one.

comment:5 by robe, 11 years ago

Summary: Invalid access to memory location in postgis-2.0.dll (windows 64-bit) 9.3 rc1Invalid access to memory location in postgis-2.1.dll (windows 64-bit) 9.3 rc1

I used the new not yet released postgis 2.1.0 installer to installer over the 2.1.1dev I had copied and it works fine. I also tested on my standalong 2.2.0 dev instance on that computer. So I'm guessing this might be a permissons issue of the original perhaps we installed by moving instead of copying. I'm going to leave this open for 2.1.1 until 2.1.1 is released so rule out any issue with 2.1.1

comment:6 by tomits, 11 years ago

I'll get this same error installing postgis 2.1 using postgis-bundle-pg93x32-setup-2.1.0-1.exe. I am using 32bit version of postgresql.

I have win7 64bit, but chose to install 32bit versions for postgresql and postgis.

comment:7 by robe, 11 years ago

hmm that is a bummer. When I installed over my install that had the issue it was fine.

Did you choose to register the GDAL path. I'm still thinking it has something to do with that. Are you installing on 9.3 or 9.3 rc1.

Do you get the same error after restarting the postgresql service.

comment:8 by tomits, 11 years ago

I didn't choose to register the GDAL path.

But restarting the postgresql did the magic. Thank you.

comment:9 by robe, 10 years ago

Resolution: worksforme
Status: newclosed

I can't replicate this anymore. So closing for now. I still thing GDAL path issue is at culprit because the install I did have issue which was just a copy from binary, when I reinstalled using installer, the issue went away.

Note: See TracTickets for help on using tickets.