Opened 8 years ago

Closed 8 years ago

#2460 closed defect (worksforme)

[raster]: Getting invalid memory access when installing postgis raster in 9.3

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.2.0
Component: raster Version: main
Keywords: Cc:

Description

I thought this was just my machine but I tested on my server and got the same results. Not sure if its something different about the way I'm compiling winnie. But when I try to do

CREATE EXTENSION postgis;

or

ALTER EXTENSION postgis UPDATE TO "2.2.0devnext";

I am getting a

 Invalid access to memory location

When updating to latest winnie 9.3.

The only difference should be that I'm compling against 9.3rc1 instead of 9.3beta1.

Since I don't clear out the install of pgx64 folder when installing, it could possibly be the result of a dirty tree.

I'm going to rebuild postgresql 9.3 rc1 and do a clean install to rule out any funkiness.

I also can't do a

select version() || ' ' || postgis_full_version();

since I get the same error.

I noticed this problem first at r11890

Change History (8)

comment:1 Changed 8 years ago by robe

forgot to say I tested on x64bit. I'm going to try a 32-bit install to see if it has the same issue.

comment:2 Changed 8 years ago by robe

Component: rasterbuildbots
Owner: changed from Bborie Park to robe

comment:3 Changed 8 years ago by robe

Sorry didn't give the full error message why I had thought it might be a raster issue:

ERROR:  could not load library "C:/Program Files/PostgreSQL/9.3/lib/rtpostgis-2.2.dll": Invalid access to memory location.

comment:4 Changed 8 years ago by robe

Summary: Getting invalid memory access when installing postgis in 9.3Getting invalid memory access when installing postgis raster in 9.3

Strangely on winnie all tests pass against 9.3 rc1 Visual C++, but the same code presumably on my windows 7 64-bit and windows 2003 64-bit database server fails. I might be shipping something that I don't realize I am.

comment:5 Changed 8 years ago by robe

Component: buildbotsraster
Owner: changed from robe to Bborie Park
Summary: Getting invalid memory access when installing postgis raster in 9.3[raster]: Getting invalid memory access when installing postgis raster in 9.3

okay I rebuilt 9.3rc1 and recompiled and still the same problem. I'm beginning to suspect something in raster that changed. I'll have to analyze this on my windows box.

I recompiled 2.1.1dev for 9.3rc1 and the issues does not exist in the 2.1.1dev only in 2.2.0 dev do I get this error.

The sad thing is the error doesn't trigger on winnie (when she's doing the EDB RC1 tests) at all and earlier 2.2.0dev (like the last one I had installed don't have this problem). I ruled out extension as the culprit since if I install with the scripts, I get an error. Both winnie and my database server are both running windows 2003 R2 64-bit so it doesn't seem specific to platform. Very frustrating that it is not always reproducable.

Last time I saw an error like this was when I didn't not have GDAL proj path set. So part of me is thinking its the introduction of that feature excp[et I think the iarlier 2.2s I tested with that had this feature were fine. I'm gong to install and test on my local to see if I can trigger the issue and where it happens by running each command separately.

comment:6 Changed 8 years ago by robe

Owner: changed from Bborie Park to robe

comment:7 Changed 8 years ago by robe

ughh I just tried the lastest build on my windows 7 box and it installs fine.

POSTGIS="2.2.0dev r11899" GEOS="3.4.2-CAPI-1.8.2 r3924" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.10.0, released 2013/04/24" LIBXML="2.7.8" LIBJSON="UNKNOWN" RASTER PostgreSQL 9.3rc1, compiled by Visual C++ build 1600, 64-bit

I can't replicate the problem anymore on my windows 7. This was taking a freshly unzipped edb 9.3rc1, copying over all the binary files from winnie zip and doing create extension postgis. the only difference last time I tried is my computer had about 1 GB left and I cleared up some space.

I will retry again on my windows 2003 r2 database server to make sure I did copy over everything.

comment:8 Changed 8 years ago by robe

Resolution: worksforme
Status: newclosed

nevermind. I can't even replicate it on my PostgreSQL 9.3 64-bit windows 2003. Perhaps it was a dependency file that was old. Only difference this time is I had to restart the service to copy over the files since other were in use. So perhaps its an issue only for installing in place.

Note: See TracTickets for help on using tickets.